Problem with D-Link DWL-G122 rev C1



  • Hello all,
    I have a problem with the installation of D-Link DWL-G122 rev C1 Wireless Network Adapter. I have installed pfSense and I have several Ethernet Controllers for my network infrastructure and everything is running just fine. But I want to add D-Link DWL-G122 rev C1. When I plug it in the USB, pfSense discovers it and offers mi to assign the new interface. When I do that and manage the wireless connection after 2 or 3 minutes the router restarts itself. Then my network is not running, my DHCP services are down and the only way to connect to the router is to plug my laptop directly in it with static network configuration. Then I have to remove the newly added interface. After this when I reboot everything is just fine. I tried again, and I tried it on a different hardware - I mean I installed pfSense on another computer - but the problem was there, too. I saw that D-Link DWL-G122 rev C1 wireless network adapter is in the recommended hardware and this is the reason I took this one. Anyone know what could be the problem?  ???



  • Have you tried pfSense 1.2.3? If not, please try it and report back.

    What CPU and chipset are involved?

    I have troubles with USB and pfSense 1.2.2 on a system with AMD 780G chipset. The troubles went away with pfSense 1.2.3



  • I have tried on P5P800-MX with Intel 865GV chipset. Also tried on GA-MA69G-S3H with AMD 690G + SB600 chipset. My pfSense version is the latest stable version that have been released and downloaded few days ago.



  • Have you tried version 1.2.3? Its still labelled "PRERELEASE"  but considered suitable for production use - see http://blog.pfsense.org/?p=377

    I presume by "latest stable version" you mean 1.2.2. The main page of the web GUI shows the software version


Locked