2.4.4 TFTP Server 413 Request Entity Too Large



  • Hi all,

    I'm running the 2.4.4 version on a VM and trying to increase the max filesize value to upload for the TFTP Server.
    So far I looked at:
    /usr/local/etc/php.ini but this one is generated by /etc/rc.php_ini_setup therefore the new values are 2000M as shown below.
    After the reboot the values are still stored but I still get the 413 error.

    Any ideas?

    Thanks,

    [2.4.4-DEVELOPMENT][admin@friday.localdomain]/: cat /usr/local/etc/php.ini
    ; File generated from /etc/rc.php_ini_setup
    output_buffering = "0"
    expose_php = Off
    implicit_flush = true
    magic_quotes_gpc = Off
    max_execution_time = 900
    request_terminate_timeout = 900
    max_input_time = 1800
    max_input_vars = 5000
    register_argc_argv = On
    register_long_arrays = Off
    variables_order = "GPCS"
    file_uploads = On
    upload_tmp_dir = /tmp
    upload_max_filesize = 2000M
    post_max_size = 2000M
    html_errors = Off
    zlib.output_compression = Off
    zlib.output_compression_level = 1
    include_path = ".:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form:/usr/local/share/pear:/usr/local/share/openssl_x509_crl/"
    display_startup_errors=on
    display_errors=on
    log_errors=on
    error_log=/tmp/PHP_errors.log
    extension_dir=/usr/local/lib/php/20170718/
    date.timezone="Europe/London"
    session.hash_bits_per_character = 5
    session.hash_function = 1
    
    
    ; Extensions
    
    
    ; opcache Settings
    opcache.enabled="1"
    opcache.enable_cli="0"
    opcache.memory_consumption="50"
    
    


  • Any thoughts guys?

    Cheers,
    N


  • Rebel Alliance Developer Netgate

    Why do you need to put a file that huge on TFTP? That is way too large to handle via simple HTTP uploads.

    Copy it to the firewall with SCP.



  • The reason is simple. An IOS for a Catalyst 3850 is larger than 500 MB.
    This has been solved.
    Thanks for taking the time to reply.

    Cheers,
    N