DHCPv6 not sharing IPs on the LAN



  • Hi.
    I had set up IPv6 with HE some time ago and has been working fine until a certain upgrade of pfSense which sadly I didn't spot (because I wasn't constantly checking IPv6 status).

    Now I'd like to restore IPv6 networking in my LAN. I re-checked the configuration and everything seems in place, at least on pfSense: I can ping HE gateway, pfSense itself on the LAN and any IPv6 host on the internet.

    I've configured RA in Assisted mode and enabled DHCPv6, but no IPv6 address is leased to client. DHCPv4 is working fine.

    Our LAN is a bridge between wifi and lan port. I've enabled IPv4+6 traffic on all the thre interfaces on the firewall.

    I tried MacOS and Linux, on both the LAN port and the WIFI interface.

    Anything else I could check to debug it?
    Thanks.



  • @maxxer,

    With RA running in Assisted mode, even if DHCPv6 were broken for some reason, the client devices should still get themselves a SLAAC address on the advertised IPv6 network.
    Check what IPv6 addresses other than fe80::xxxx the clients are actually getting.
    The fact that it isn't happening suggests that RA isn't running, the advertising is being blocked, or a 3rd device is sending other, wrong, RA information.

    Other things to check:

    • Check pfSense system logs for any errors about DHCPv6 / RA issues;
    • Check output of CLI: cat /var/etc/radvd.conf make sure expected prefix is showing up there;
    • Take packet captures (ipv6 only) on client system to see if it is seeing RA packet from time to time (could be once every few minutes), and that advertised prefix is what is expected.


  • @maxxer said in DHCPv6 not sharing IPs on the LAN:

    Our LAN is a bridge between wifi and lan port.

    Use a wired IPv6 device to test directly a LAN interface.
    (Your Wifi AP, if reset, could have ditched IPv6 support)



  • after upgrading pfSense to 2.4.4 IPv6 assignment is back working again, without doing anything. maybe there was a bug I missed? Thanks anyway everyone for helping