Install pfSense in a microserver HP Gen10

  • Hi.
    I have a problem when I try to install the pfSense 2.4 in a microserver gen10 HP.

    When you try to install FreeNAS 11 on the new HPE ProLiant MicroServer Gen10 X3216, the installer stops booting and appears to be stuck at:

    pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
    pcib0: _OSC returned error 0x10
    pci0: <ACPI PCI bus> on pcib0

    I Interrupt the boot process to reach the boot loader prompt and then in the consolle menu I put this command:

    set hw.pci.realloc_bars=1

    My question is.....
    Where is the correct file where I put this line for skip this problem in the next startup of the server?



  • LAYER 8 Global Moderator

    @charneval said in Install pfSense in a microserver HP Gen10:

    MicroServer Gen10 X3216

    Would not be my choice for a firewall.. I have to assume just something had laying around?

  • 873830-421
    HPE ProLiant MicroServer Gen10 X3216, 8GB DDR4 up to 32GB, 4x LFF SATA, 2x Gigabit Ethernet, 4x USB3.0, 2x USB 3.0, 2x Display Port, 2x PCIe 3.0, 200W PS, Entry Server

  • LAYER 8 Global Moderator

    Yeah not a good choice for a router/firewall... What you need 4 Bays for... Why would you need All that graphics stuff for... You sure and the hell do not need all those USB ports on your router/firewall.

    If you want to make it your VM host and run pfsense as a VM.. Ok... But to put baremetal pfsense on that is just not a good fit if you ask me.. But hey good luck..

    How much juice it draw sitting idle? There is much better suited hardware for a router/firewall. Its go only 2 nics - can you add more?

  • This server last week run with proxmox and some vm inside togheter pfsense. But now for test I tried to put pfsense because the performance in a vm installation are different that a bare metal installation.

    But the problem of the acpi now block my test.

    Do you think there is a solution for boot the server without the acpi stop ?


  • LAYER 8 Global Moderator

    There might be - but who cares, lets say you fix that.. And then put pfsense on it baremetal.. And lets say the performance is ok. Still makes is 1 hell of a lousy choice for a router/firewall..

    I would would look more to seeing what might be done about the performance of pfsense on proxmox

    I assume you setup per?

    Did you disable TX offload? That comes up on simple google.

  • @charneval
    You can try to write the setting into the loader.conf.local.

    Boot the machine to the boot menu, select 3 (loader prompt), then enter

    echo "hw.pci.realloc_bars=\"1\"" >> /boot/loader.conf.local

    See if it works.

  • Thanks for your response but this solution doesen't work when reboot the pfsense and now I installed in this server Proxmox with a VM with pfSense.

    The VM with pf works fine and now I would like to configure a minimal filtering web content http and https.

    Do you have any suggestion to do this?



  • Netgate Administrator

    /boot/loader.conf.local is the correct location for that but that command might not have worked. You don't need the quotes anyway. Just edit that file and add the line, you can do that from the GUI or using the ee editor at the CLI.


  • Thanks.
    Now I put the pfsense in Proxmox and with this system I resolved my problem.

    Thanks for your support.


Log in to reply