2.4.3_1 CRON WOL



  • Hello all,

    I am having some difficulty starting a machine with a cron command. I have used this before with success on 2.3.5 running as a VM. I have now moved to a physical box running 2.4.3_1

    I have installed the CRON package and added:

    /usr/local/bin/wol -i 192.168.0.255 xx:xx:xx:xx

    My wan ip is 192.168.0.5 so, yes I am trying to wake up the box on the wan side. I've checked the time is set correctly within pfsense itself.

    I can use the WOL tool in pfsense to wake this box and other tools in windows to wake this box. For some reason the cron command is failing. I cannot see any entries in the logs.

    Any ideas at all please?

    Cheers



  • @flashpan said in 2.4.3_1 CRON WOL:

    /usr/local/bin/wol

    Hi,

    You tried packet sniffing on the WAN interface (wiresharking) ?
    If 192.168.0.5 is a Windows PC, install https://www.depicus.com/wake-on-lan/wake-on-lan-monitor so you can see if wake up packets make it too this PC.

    Btw : never used WOL to wake up devices "upstream" although I managed ones to wake up my PC @home through my ISP box, from my work.



  • Hi there,

    Sorry I was not concise enough 192.168.0.5 is my wan IP on pfsense. This is the connected to an ISP router with an internal IP 192.168.0.1. Another box is connected to the ISP router with the IP of 192.168.0.232. So you could say nothing is reaching out across the internet but reaching out from the wan side of pfsense.

    The built in wol client on pfsense gives the option to direct the wol packet to to the wan or lan interface. Hence why I can wake up this .232 box from the wan interface manually.

    I've checked with the ISP/router and nothing has changed there at all.

    The only change to my setup is that I have moved to a new box and newer version of pfsense.

    A shot in the dark but does the built in wol client use a different method/command to the wol command I am trying to cron? BTW the cron command is set to run as "root"

    Cheers



  • @flashpan said in 2.4.3_1 CRON WOL:

    For some reason the cron command is failing

    Typing the wol command on console access or SSH access wakes up your 232 on WAN ?
    Diagnostics => Packet Capture told you what ?



  • @flashpan said in 2.4.3_1 CRON WOL:

    Hi there,

    Sorry I was not concise enough 192.168.0.5 is my wan IP on pfsense. This is the connected to an ISP router with an internal IP 192.168.0.1. Another box is connected to the ISP router with the IP of 192.168.0.232. So you could say nothing is reaching out across the internet but reaching out from the wan side of pfsense.

    The built in wol client on pfsense gives the option to direct the wol packet to to the wan or lan interface. Hence why I can wake up this .232 box from the wan interface manually.

    It would have been more concise to say the other device is in the same subnet and broadcast domain as the pfSense WAN, but behind the ISP's provided router.



  • I was as concise as I thought was needed. Considering I had already setup this cron event previously with no issue, no special config to make and as laid out in my first post.

    The pfsense wan and ISP router are in the same subnet and broadcast domain (same as the the device I am trying to wake).

    But thank you for you wise words.

    When I get home I'll attempt to run the command in ssh and report back.



  • RESOLVED: So...SSH woke the .231 machine buthe cron package would still not wak the machine. Only option (which I am sorry I did not consider earlier) was then to uninstall the cron package, reboot pfsense, install the cron package.

    After that the cron command worked.

    Not sure why the cron package did not work before.

    Cheers



  • Consider this a low priority bug.
    pfSense has a menu item in the status menu : Package logging. And guess what, I didn't find yet one package that logs its output over there. Worse : huge loggers like FreeRadius log in the "main" pfSense log file "system", or, I really think it shouldn't.
    Why I'm talking about this ? Because you would have seen that your cron didn't work ... because not logs ... Every major OS these days have a cron.log.

    But glad it worked out for you.