IPSec Site to Site requires port 500 open on WAN?



  • Hello!

    I'm currently testing a site-to-site IPSec to replace our Fortinet routers, and I ran into an issue when configuring a simple VPN. I did the basic setup, followed a tutorial from here: [https://www.ceos3c.com/pfsense/pfsense-site-to-site-vpn/](link url)

    I'm running pfSense 2.4.3 on both ends for testing, but ran into an issue with the VPN traffic being blocked (port 500). The tunnels report active, but no traffic passes.

    I also read several other tutorials from older versions (pre 2.4), and none of them specify that a WAN rule needs to be set up- several listed a NAT rule which I tried, but still did not work. I figured out how to track the traffic using the firewall logs, and found all of the port 500 traffic from the external site being blocked by the 'default deny' rule. I used the quick create function from the logs to open up the ports temporarily, which worked instantly as my IPSec rule was already set to allow all.

    Is this normal, or was something missed on the tutorial? The reason I ask is, one side of the test connection uses dynamic dns, and I can't program that in even via an alias in the firewall rules source field.

    I'm just confused by the fact that I had to troubleshoot this when none of the guides show that port 500 needs to be open to initiate the IKE connection. Is this a bug?


  • LAYER 8 Netgate

    Rules that pass IKE traffic (udp/500), ESP, and NAT-T (udp/4500) traffic are automatically created when a tunnel exists and is enabled.

    You'll have to provide more information about what exactly you were seeing blocked, from where, the tunnel configs, etc.


  • Banned

    @derelict said in IPSec Site to Site requires port 500 open on WAN?:

    Rules that pass IKE traffic (udp/500), ESP, and NAT-T (udp/4500) traffic are automatically created when a tunnel exists and is enabled.

    Unless he turned it off in the advanced settings.


  • LAYER 8 Netgate

    That would be information I would expect to be provided. If not, then that's OP's problem and will only delay assistance.


Log in to reply