IPcomp going to be fixed in 2.4.4?



  • For quite a few releases now, with each release, the fix for IPSec IPcomp gets pushed out to the next release.

    Now, given that 2.4.4 uses a new OS, new version of the underlying IPSec software, my hopes were quite high, that 2.4.4 would finally fix this.

    So after biting the bullet and installing the latest 2.4.4 prerelease build, I notice that my VPN connection still doesn't use IPComp, even though the settings tell it to.

    Now, I know that in order to prevent the bug from being triggered, that setting was essentially rendered a NoOp quite some time ago.

    So, here the question:
    Is IPcomp fixed, but it was forgotten to activate the setting again, or despite all the new piping underneath, IPcomp still doesn't work?



  • Checkout the works for 2.4.4 : not much to do https://redmine.pfsense.org/projects/pfsense/issues?fixed_version_id=46&set_filter=1&status_id=o and your issue is still in the list. Cross fingers !?


  • Rebel Alliance Developer Netgate

    No progress was made on that and it's not going to be in 2.4.4 unless it happened to work from underlying OS changes without our intervention.



  • Bummer, it does add a noticeable amount of throughput on my line, which is bandwidth limited and has a monthly data cap.

    Still, with the preference setting turned into a no-op, did anyone actually try if it would work? There have been substantial changes in the underlying software, that it may work, after all, in a time long ago, it used to work fine, too.


Log in to reply