Telekom Zuhausestart



  • Hallo,
    aufgrund eines Umzuges habe ich jetzt Zuhausestart von der Telekom, d. h. ich wohne in einem VDSL Ausbaugebiet von NetAachen und habe einen Vertrag bei der Telekom.

    Die pppoe Verbindung muss über VLAN7 aufgebaut werden. Das ist kein Problem. Problematisch ist die VOIP Verbindung. VOIP muss über VLAN8 mittels einer eigenen pppoe Verbindung laufen. Die pppoe Verbindung mit VLAN 8 bekomme ich auch aufgebaut, aber das SIP Telefon bekommt keine Verbdinung. Der registrar ist wohl tel.zuhausestart.de. Nslookup liefert folgendes Ergebnis

    [alex@wsalex ~]$ nslookup tel.zuhausestart.de
    Server:         10.0.1.1
    Address:        10.0.1.1#53
    
    Non-authoritative answer:
    tel.zuhausestart.de     canonical name = tel.zuhausestart.qsc.de.
    
    [alex@wsalex ~]$ 
    
    

    Ein ping auf tel.zuhausestart.qsc.de ist nicht möglich, auch kein nslookup.

    [alex@wsalex ~]$ nslookup tel.zuhausestart.qsc.de
    Server:         10.0.1.1
    Address:        10.0.1.1#53
    
    Non-authoritative answer:
    *** Can't find tel.zuhausestart.qsc.de: No answer
    
    [alex@wsalex ~]$ 
    
    

    In der beigefügten Anleitung der Telekom, wie eine Fritzbox 7490 ohne Firmwareupdate für Zuhausestart einzurichten ist, sind die sip Einstellungen zu entnehmen.

    [0_1536669554337_zuhause-start-fritzbox-7490-ohne-firmware.pdf](Uploading 100%) 0_1536669578378_zuhause-start-fritzbox-7490-ohne-firmware.pdf.zip

    Hat hier vielleicht einer Erfahrungen, wie die Telekom sip Accounts bei Zuhausestart einzurichten sind, ohne dass ein Zangsgerät der Telekom verwendet werden muss?

    Besten Dank und viele Grüße
    Alex


  • Moderator

    Bei der Anleitung drängt sich mir die Vermutung auf, dass da wieder was Telekom-seitig entweder nicht betriebsbereit/voll umgesetzt wurde oder - fast wahrscheinlicher - wieder mal saumäßig durch den Login umgesetzt wird.

    Ich habe versucht aus der Domain bzw. dem Alias etwas auszulesen, aber tel.zuhausestart.qsc.de hat keinerlei DNS verwertbare Einträge. Eine VoIP Anmeldung an einem Dienst, der keinen A, AAAA, SRV oder TXT Record hat, dürfte relativ schwer fallen, es sei denn die mauscheln das wie damals wieder via PPPoE/DSL Login und leiten dann abhängig davon ob man eingewählt ist oder nicht einfach durch die Anschlußkennung um oder lösen den DNS erst auf, wenn man per DSL verbunden die eigenen Telekomserver nutzt. Dann wäre der Dienst aber nur schwerlich mit anderen Geräten bzw. eigenem DNS nutzbar. Somit leider keine Ahnung, wie das geplant ist. Dass das Telefon aber keine Verbindung bekommt, wenn die Domain keine Einträge aufweist, wundert mich nun nicht so sehr :/

    Gruß



  • Hallo @beppo (Der Name ist aber nah an meinem :-D),

    wie sieht die Statusseite für dein PPPoE Interface im VLAN 8 aus? Hast du dort IP, Gateway und Co bekommen? Was sagt das PPPoE Log?
    Wählst du beim Ping test das richtige Quell Interface aus?

    Ich könnte mir vorstellen, dass sich tel.zuhausestart.de nur mit den von der Telekom im VLAN 8 mitgegebenen DNS Servern auflösen lässt. Eventuell kannst du im DNS Resolver für die Domain zuhausestart.de dann den Telekom VLAN 8 DNS Server als Ziel angeben. > EDIT: tel.zuhausestart.de lässt sich auch normal auflösen. Aber zumindest das Routing wirst du in das Netz anpassen müssen?

    Viele Grüße


  • Moderator

    @bepo said in Telekom Zuhausestart:

    EDIT: tel.zuhausestart.de lässt sich auch normal auflösen.

    Von wo lässt sich das auflösen? Ich bekomme es lediglich als CNAME und das Ziel davon hat keinerlei Einträge, was nebenbei erwähnt Murks ist, sowas sollte man im DNS nicht tun - aber hey, Telekom konnte schon immer solche Dinger durchboxen die fragwürdig sind.



  • @jegr ich konnte es in https://toolbox.googleapps.com/apps/dig/#ANY/ auflösen.
    Mann muss halt NAPTR Records verwerten können. Keine Ahnung, ob die Telefoniegeräte von @beppo das können.

    Aber es geht bis auf farm1.tel.zuhausestart.qsc.de und farm2.tel.zuhausestart.qsc.de runter.


  • Moderator

    Uff... also man kanns auch echt kompliziert machen. Vor allem nicht nur tief streuen, sondern dann auch noch zigfach schachteln... Wenn eh nur alles Pointer und Referenzen sind, dann auch noch mit nem CNAME zu starten, ist schon... nunja ;) Aber danke, checks auf ANY musste ich schon länger nicht mehr machen. Und dass da lediglich ein NAPTR dranhängt - ja gut :)



  • Also, erstmal vielen lieben Dank für Eure Hilfe @JeGr and @bepo !

    Die pppoe Verbindung mit VLAN8 für voip bekomme ich aufgebaut. Als Zugangsdaten nehme ich meine normalen aber dann @tel.zuhausestart.de. 0_1536781124474_interfaces_vlan7_und_vlan8.png

    0_1536781129532_interfaces_vlan7.png
    0_1536781136365_interfaces_vlan8.png

    Der Gateway ist bei beiden pppoe Verbindungen gleich, die VLAN7 Verbindung (Internet) bekommt zwei DNS Server zugewiesen, die VLAN8 Verbindung (voip) keinen.

    Mein sip Telefon ist ein Gigaset C430A IP. Keine Ahnung ob das NATPR Records auflösen kann. Mit tel.zuhausestart.de bekomme ich keine Verbindung. Ich werde morgen mal farm1.tel.zuhausestart.qsc.de ausprobieren und berichten.

    Ist auf jeden Fall ein Witz, was die Telekom sich mit zuhausestart leistet. IPV6 funktioniert auch nicht mehr bei zuhausestart. Und Zwangsrouter sind meiner Meinung nach gesetzlich verboten. Hätte ich vor dem Umzug gewußt, dass es so ein Theater wird, hätte ich direkt NetAachen genommen.



  • Also das Siemens C430A IP kann den sip account nicht registrieren mit farm1.tel.zuhausestart.qsc.de oder farm2.tel.zuhausestart.qsc.de. Mit oder ohne DNS SRV Lookup hat auch keinen Einfluß - "ja'" verschwindet der Port beim Proxy und registrar und wird anscheinend automatisch ausgehandelt.

    0_1536786712515_voip_account.png

    Bei den Netzwerk Einstellungen kann ich noch VLAN8 wählen, aber dann ist das Telefon Webinterface nicht mehr erreichbar und das Mobilteil meldet keine LAN Verbindung. Ob es hilft, dem Telefon irgendwie in den pfsense Einstellungen den zweiten pppoe Account als Gateway zuzuordnen?

    0_1536786724994_voip_netzwerk.png

    Die Telefonnummer habe ich nur mit Ortsvorwahl oder auch mit +49 ausprobiert (und Weglassen der 0), beides Mal ohne Erfolg.

    Ich weiß zur Zeit nicht weiter. Habt Ihr vielleicht noch eine Idee?


  • Moderator

    Ich kenne das Setup mit 2 PPPoE und VLAN nicht (musste schon seit Jahren kein DSL mehr wirklich zum Laufen bekommen), aber rein logisch sieht das für mich böse aus, wenn 2 Verbindungen zwar unterschiedliche IPs, aber das gleiche Gateway haben. Da das Gateway ja im Normalfall als Route aufs Interface geht -> wie soll er jetzt was über VoIP rausschicken. Sieht irgendwie nicht so durchdacht oder richtig aus, es sei denn es wird vorausgesetzt, dass man böse mit policy based routing und floating rules rumbastelt, damit jeder VoIP Traffic über das Interface geht - wobei dann trotzdem noch die Frage ist, ob die Routing Tabelle nicht im Quadrat speiht, wenn 2x die gleiche IP als Gateway gezogen werden.

    Gruß



  • Da bin ich auch etwas überfragt. Bei EntertainTV musste man ja vor BNG auch so Sachen machen. Da gabs aber wenigstens ein eigenes Gateway dafür.

    Mit fällt auf, dass du im VLAN8 Interface laut deinem Screenshot nur ausgehende Pakete hast. Du erhältst also gar keine Antwort auf deinen Traffic. Könnte es sein, dass der Traffic von deinem Telefon über die Default Outbound NAT Rule mit der VLAN7-Public-IP geNATet wird und daher nie am VLAN8 wieder ankommt?

    Versuch mal mit einer Outbound NAT Regel den Traffic deines Telefons auf die VLAN8 Interface Address zu übersetzen. Einstellungen im Telefon bitte so wie in der Telekom Anleitung vorgegeben.

    @JeGr was denkst du darüber?


  • Moderator

    @bepo said in Telekom Zuhausestart:

    @JeGr was denkst du darüber?

    Wäre eine Möglichkeit, allerdings könnte das Routing immer noch ziemlich durcheinander sein, weil er das Default GW eigentlich über VLAN7 bugsieren will. Käme auf den Versuch an



  • Ich habe mal firewall Regeln als auch NAT eingestellt.

    rules for LAN
    0_1536922518251_route_sip_traffic.png
    NAT

    0_1536922529003_route_sip_traffic_nat.png

    NAT outbound
    0_1536922535721_route_sip_traffic_nat_outbound.png

    log
    0_1536922572566_roue_sip_traffic_log.png

    Die Einstellungen scheinen zu funktionieren, siehe dem log. Der testweise eingestellte STUN tel.zuhausestart.de scheint angefragt zu werden, obwohl bei reverse lookup der IP 148.251.243.162 folgendes aussagt:

    0_1536930148088_dns_stun.png

    Aber außer der Anfrage an port 3478 ist im log nichts zu sehen.

    Was ich mich noch frage, ist es ausreichend der zweiten pppoe Verbindung (für voip) die VLAN ID 8 zuzuweisen, oder müßte ich dem VOIP Telefon auch noch das VLAN8 Tag zuweisen?

    Wenn ich alles richtig verstehe, dann muss es ausreichen, dass pfsense die pppoe Verbindung mit VLAN8 tagged. D. h. ich schliesse ein sip Telefon an LAN network an und route den Traffic über die ppoe Verbindung mit VLAN8.

    Gleiches gilt ja auch für die pppoe Verbindung mit VLAN7 für den "normaleTraffic. Diese pppoe Verbindung hat das VLAN Tag 7 und das LAN network angeschlossen an pfsense hat ja kein VLAN Tag.

    Ich denke, ich werde mir mal ein linux sip softphone besorgen. Mit Sicherheit kann man dem log einer sip software mehr entnehmen, als meinem Siemens C430A IP - das hat gar kein log.



  • Guten Morgen,
    mittlerweile habe ich es, auch dank Eurer Hilfe geschafft, voip bei meinem Zuhausestart Anschluss einzurichten. Mit Zuhilfenahme von linphone und Beobachtung der logs, nachdem ich in linphone testweise einen voip Account (Zuhausestart) eingerichtet habe, wurde einiges klarer

    Was ist dabei in Kombination mit pfsense zu beachten?

    • Internet läuft über VLAN7 über pppoe, Format 123456789@zuhausestart.de,
    • eine zweite pppoe Verbindung mit VLAN8 ist für die voip Verbindungen notwendig, Format 123456789@tel.zuhausestart.de (die ip kommt aus dem selben 24er Subnetz),
    • das voip Telefon muss mit NATPR Einträgen umgehen können (ich habe ein neues gekauft und zwar ein Yealink W60B),
    • als Registrar habe ich folgende Server eingetragen farm1.tel.zuhausestart.qsc.de und farm2.tel.zuhausestart.qsc.de, beide mit UDP Port 5060 (auch das Yealink konnte tel.zuhausestart.de nicht auflösen, mit farm1... und farm2... lassen sich die sip accounts jedoch registrieren),
    • RTP ports eingestellt im Yealink sind 7078-7090 (diese können nach belieben gewählt werden),
    • die Telefonnummern werden in dem Format Ortsvorwahl + Telefonnummer + @zuhausestart.de eingetragen (bei Registrierung und Benutzername),
    • das Passwort für beide pppoe Verbindungen und für die sip accounts ist immer das Gleiche, d. h. das "normale Internetpasswort",
    • ein STUN Server wird nicht verwendet,
    • ein Outbound Proxy ebenfalls nicht,
    • der gesamte Voip Traffic eingehend als auch ausgehend wird über die zweite pppoe Verbindung mit VLAN8 geroutet.

    Das sollten die wesentlichen Punkte sein. Anbei noch ein paar Screenshots. Das Telefon läuft absolut stabil - ich denke, zumindest so lange bis die Telekom auf die Idee kommt irgendwas zu ändern. Wobei ich denke, dass sich u. U. die Auflösung der NATPR Records ändern können - was allerdings eine wilde Spekulation von mir ist. Im Grunde genommen, ist das Setup zumindest hinsichtlich den Einstellungen auf pfsense ziemlich logisch.

    Das voip Telefon hat die Adresse 10.0.1.15 in meinem LAN.

    Übersicht pppoe
    0_1539506174212_uebersicht_pppoe_verbindungen.png

    Firewall Rules - ich habe keine Floating Rules
    0_1539506491005_firewall_rules_lan.png
    0_1539506498343_firewall_rules_wan_vlan8.png

    NAT - ich habe kein Outbound NAT eingerichtet, das routing von voip über pppoe2/VLAN8 geht über Firewall Rules
    0_1539506561291_nat_rules_port_forward.png

    sip Konto im Yealink
    0_1539507251333_einstellungen_voip_account_yealink.png

    Nochmals vielen Dank für Eure Hilfe @bepo und @JeGr!

    Gerne könnt Ihr den Post oben anpinnen, falls Ihr das für sinnvoll erachtet. Ich denke, eine solche Anleitung für voip unter zuhausestart bei der Verwendung von nicht-Telekom Geräten gibt es zur Zeit nirgends im Netz :).

    Viele Grüße
    Alex



  • Hallo @beppo,

    schön, dass es geklappt hat! Danke fürs Feedback geben!

    Viele Grüße