Problem ppoe



  • Hi
    update to pfSense-Full-Update-1.2.3-20090218-2009
    cannot access internet using Ppoe anymore

    Feb 19 07:51:29 	kernel: sk0: link state changed to DOWN
    Feb 19 07:51:28 	mpd: mpd: process 1883 terminated
    Feb 19 07:51:26 	mpd: mpd: caught fatal signal term
    Feb 19 07:51:26 	mpd: Warning: no secret for "BS105" found
    Feb 19 07:51:26 	mpd: Using authname "BS105"
    Feb 19 07:51:26 	mpd: Name: "BS105"
    Feb 19 07:51:25 	php: /interfaces_wan.php: foreach if is wan
    Feb 19 07:51:25 	php: /interfaces_wan.php: foreach if is lan
    Feb 19 07:51:22 	mpd: Warning: no secret for "BS105" found
    Feb 19 07:51:22 	mpd: Using authname "BS105"
    


  • I got hit with that this morning myself.
    I'm on the livecd for the stable version now and in comparing
    /var/etc/mpd.conf

    i see on the livecd

    set bundle authname "medonthackme@att.net"
    set bundle password "h4x0rsupREEM"

    my /var/etc/mpd.conf on my 1.2.3 used "set auth" and system logs showed that's not a valid command.
    I'm going to edit my mpd.conf and see if i can drop and reload the interface.

    my mpd.conf keeps getting overwritten, i'd like to find the source php script or whatever function writes to this file so i can change it there.
    still new to pfsense but loving it!

    ..i'll be back



  • Hi, it happened to me too. I can not connect to the Internet via PPPoE anymore since I installed yesterday’s and today’s pfSense-1.2.3.-Snapshots on my box. The earlier Snapshots worked just fine, though. Getting back to one of them solves the problem for me, but I am interested in a more future-oriented general solution for this shortcomings.

    I started testing those 1.2.3 snapshots in early February. Here I finally found a firewall distribution that worked out-of-the-box on my mini-itx computer based on the im-945gse-a motherboard. Other distributions, IPCop, Endian, SmoothWall to name a few, just failed to install or refused to work on my system, because they driver-wise lacked support for some hardware components. Seemingly the ethernet controllers and sata devices aren’t fully supported by linux-based and pre-FreeBSD-7.1 firewall distributions yet. FreeBSD 7.1 and pfSense 1.2.3 respectively did the trick for me – for some time at least.

    I kept my 1.2.3 pfSense box up to date, updating to the latest snapshot daily. Meanwhile I tried to learn by doing and by some googleing how to set up firewall rules, squid, squidguard and so on. Everything worked just fine based on all the snapshots I tried out till February 11.

    But: Since I upgraded from pfSense-1.2.3-20090211-1551 to the newer snapshots from February 18 and 19 my pfSense-Router/Firewall fails to connect to the Internet via PPPoE. My PPPoE configuration does not seem to be faulty. I kept it the same anyway and that way it worked perfectly on any 1.2.3.-Snapshot released before February 18.

    Since I am new to pfSense and FreeBSD I would appreciate any hints about which system-log-data I should post to help in trouble-shooting this issue.



  • Yes i have same problem too, i cannot connect pppoe, the service provider says username and password is wrong, when i connect my ethernet to laptop i can connect pppoe successfully.
    I downgraded to 1.2.2 now

    Regards
    Yuregir



  • Hi, the PPPoE problem persists. I just uploaded the firmware pfSense-Full-Update-1.2.3-20090223-1231 to my pfSense-1.2.3-snapshots-testing-box. As a consequence of this upgrade my PPPoE connection gets disconnected and I can not bring it up anymore.

    While the PPPoe connection refuses to work with that February 23 pfSense-1.2.3-Snapshot, in my system log appear these two lines, obviously concerning an authentication problem:

    mpd: mpd: empty auth name

    mpd: Warning: no secret for "" found

    I edited /var/etc/mpd.conf – there I find two lines concerning my authname and password. My Username and Password do appear here exactly and correctly like I wrote them into the PPPoE configuration menu for the WAN Interface.

    PPPoE connection worked with earlier snaphots up to pfSense-1.2.3-20090211-1551. So I compared my mpd.conf. from February 11 to that of February 23. They differ in just two lines.

    set bundle authname "my_adsl_username#0001@t-online.de"
    set bundle password "my_adsl_password" (Feb 11)

    set auth authname "my_adsl_username#0001@t-online.de"
    set auth password "my_adsl_password" (Feb 23)

    Any hints how to solve this PPPoE / MPD / WAN configuration issue or at least how to help in solving it are welcome.

    Regards,

    jaybird


    WAN interface (em1) Status up
    PPPoE down

    Media 10baseT/UTP <half-duplex>In/out packets 70/236 (4 KB/8 KB)
    In/out errors 0/0
    Collisions 0

    Last 50 system log entries

    Feb 23 20:59:17 mpd: AUTHPROTO PAP
    Feb 23 20:59:17 mpd: MAGICNUM 3783f113
    Feb 23 20:59:17 mpd: MRU 1492
    Feb 23 20:59:17 mpd: AUTHPROTO PAP
    Feb 23 20:59:17 mpd: MAGICNUM 3783f113
    Feb 23 20:59:17 mpd: MRU 1492
    Feb 23 20:59:17 mpd: MAGICNUM 692e687b
    Feb 23 20:59:17 mpd: mpd: empty auth name
    Feb 23 20:59:17 mpd: Warning: no secret for "" found
    Feb 23 20:59:19 mpd: mpd: empty auth name
    Feb 23 20:59:19 mpd: Warning: no secret for "" found
    Feb 23 20:59:21 mpd: mpd: empty auth name
    Feb 23 20:59:21 mpd: Warning: no secret for "" found
    Feb 23 20:59:56 php: /interfaces_wan.php: foreach if is lan
    Feb 23 20:59:56 php: /interfaces_wan.php: foreach if is wan
    Feb 23 20:59:58 mpd: mpd: caught fatal signal term
    Feb 23 21:00:00 mpd: mpd: process 251 terminated
    Feb 23 21:00:02 mpd: mpd: pid 1122, version 3.18 (root@freebsd7-releng_1_2_3-pre-testing.pfsense.org 17:34 22-Feb-2009)
    Feb 23 21:00:02 kernel: em1: link state changed to DOWN
    Feb 23 21:00:02 mpd: set auth: unknown command. Try "help".
    Feb 23 21:00:02 mpd: set auth: unknown command. Try "help".
    Feb 23 21:00:04 kernel: em1: link state changed to UP
    Feb 23 21:00:07 check_reload_status: rc.linkup starting
    Feb 23 21:00:17 mpd: MRU 1492
    Feb 23 21:00:17 mpd: MAGICNUM 89e4aa92
    Feb 23 21:00:17 mpd: MRU 1492
    Feb 23 21:00:17 mpd: AUTHPROTO PAP
    Feb 23 21:00:17 mpd: MAGICNUM 7905e29a
    Feb 23 21:00:17 mpd: MRU 1492
    Feb 23 21:00:17 mpd: AUTHPROTO PAP
    Feb 23 21:00:17 mpd: MAGICNUM 7905e29a
    Feb 23 21:00:17 mpd: MRU 1492
    Feb 23 21:00:17 mpd: MAGICNUM 89e4aa92
    Feb 23 21:00:17 mpd: mpd: empty auth name
    Feb 23 21:00:17 mpd: Warning: no secret for "" found
    Feb 23 21:00:19 mpd: mpd: empty auth name
    Feb 23 21:00:19 mpd: Warning: no secret for "" found
    Feb 23 21:00:21 mpd: mpd: empty auth name
    Feb 23 21:00:21 mpd: Warning: no secret for "" found
    Feb 23 21:00:33 check_reload_status: reloading filter
    Feb 23 21:00:34 dnsmasq[466]: exiting on receipt of SIGTERM
    Feb 23 21:00:35 dnsmasq[1396]: started, version 2.45 cachesize 150
    Feb 23 21:00:35 dnsmasq[1396]: compile time options: IPv6 GNU-getopt BSD-bridge ISC-leasefile no-DBus no-I18N TFTP
    Feb 23 21:00:35 dnsmasq[1396]: no servers found in /etc/resolv.conf, will retry
    Feb 23 21:00:35 dnsmasq[1396]: no servers found in /etc/resolv.conf, will retry
    Feb 23 21:00:35 dnsmasq[1396]: read /etc/hosts - 2 addresses
    Feb 23 21:00:36 dhcpd: Internet Systems Consortium DHCP Server V3.0.5
    Feb 23 21:00:36 dhcpd: Copyright 2004-2006 Internet Systems Consortium.
    Feb 23 21:00:36 dhcpd: All rights reserved.
    Feb 23 21:00:36 dhcpd: For info, please visit http://www.isc.org/sw/dhcp/

    /var/etc/mpd.conf

    pppoe:
    new -i ng0 pppoe pppoe
    set iface route default
    set iface disable on-demand
    set iface idle 0
    set iface up-script /usr/local/sbin/ppp-linkup
    set bundle disable multilink
    set auth authname "my_adsl_username#0001@t-online.de"
    set auth password "my_adsl_password"
    set bundle no noretry
    set link keep-alive 10 60
    set link max-redial 0
    set link no acfcomp protocomp
    set link disable pap chap
    set link accept chap
    set link mtu 1492
    set ipcp yes vjcomp
    set ipcp ranges 0.0.0.0/0 0.0.0.0/0
    set ipcp enable req-pri-dns
    set ipcp enable req-sec-dns
    open iface</half-duplex>



  • maybe  changing  "set auth" to "set bundle" in mpd.conf work

    set bundle authname "my_adsl_username#0001@t-online.de"
    set bundle password "my_adsl_password"
    ?



  • Hi,

    it seems like the new interfaces.inc file was to blame. I have just changed these lines in my interfaces.inc – /etc/inc/interfaces.inc --.

    Where it said:

    set auth

    I changed it "back" to:

    set bundle

    After applying this somewhat quick & dirty change to the interfaces.inc file, PPPoE connection works again on today's 1.2.3-snapshot!

    Regards,
    jaybird



  • Hi again,

    I have just re-applied my previously posted workaround for that PPPoE problem to the newest snapshot I could get:

    pfSense-Full-Update-1.2.3-20090223-1749

    Yes, it works.

    Bringing the PPPoE connection up again involved the following:

    Diagnostics: Edit File

    Save/Load from path: /etc/inc/interfaces.inc

    Now looking for lines saying:

    set auth

    (I found four "set auth" lines in my interfaces.inc)

    Then changing every instance of set auth in interfaces.inc to:

    set bundle

    Save these changes to: /etc/inc/interfaces.inc

    Interfaces: WAN

    PPPoE configuration

    save

    (Yes, save it again.)

    Status: Interfaces

    PPPoE

    connect

    (waiting some 30 seconds…)

    Done!

    And accordingly (things change back to):

    WAN interface (em1) 
    Status up 
    PPPoE up

    Loaded text from /var/etc/mpd.conf

    pppoe:
    new -i ng0 pppoe pppoe
    set iface route default
    set iface disable on-demand
    set iface idle 0
    set iface up-script /usr/local/sbin/ppp-linkup
    set bundle disable multilink
    set bundle authname "my_adsl-username#0001@t-online.de"
    set bundle password "my_adsl_password"
    set bundle no noretry
    set link keep-alive 10 60
    set link max-redial 0
    set link no acfcomp protocomp
    set link disable pap chap
    set link accept chap
    set link mtu 1492
    set ipcp yes vjcomp
    set ipcp ranges 0.0.0.0/0 0.0.0.0/0
    set ipcp enable req-pri-dns
    set ipcp enable req-sec-dns
    open iface

    Any suggestions, feedback or comments on this issue is most welcome. I wonder if some of you tried that trick described above, and if there are known yet better solutions for the PPPoE problem at this time.

    Regards,
    jaybird



  • worked like a charm for me nice to have ppoe back agin



  • Confirmed. It works now.

    Sasa



  • im glad its working
    thanks jaybird



  • Had the sma problem and this fixed the issue. Could a dev fix this in the code?



  • also had this problem in latest snapshot.  workaround implemented in interfaces.inc while waiting for fix. Thanks



  • Fixed, thanks.



  • I want to  report that using :

    1.2.3-PRERELEASE-TESTING-VERSION
    built on Thu Mar 5 07:23:55 EST 2009

    the problem persists , in order the situation to  be fixed you have to edit /etc/inc/interfaces.inc
    and change set auth instances to  set bundle

    so the fix AINT WORKING



  • @pipis9242:

    1.2.3-PRERELEASE-TESTING-VERSION
    built on Thu Mar 5 07:23:55 EST 2009

    so the fix AINT WORKING

    Try again with

    1.2.3-PRERELEASE-TESTING-VERSION
    built on Fri Mar 6 17:16:59 EST 2009

    It seems the patch was first applied to that version. I had the same problems with the version you mentioned, but the latest build fixed it.



  • @pipis9242:

    I want to  report that using :

    1.2.3-PRERELEASE-TESTING-VERSION
    built on Thu Mar 5 07:23:55 EST 2009

    the problem persists , in order the situation to  be fixed you have to edit /etc/inc/interfaces.inc
    and change set auth instances to  set bundle

    so the fix AINT WORKING

    Yes it is working. Evidently I needed to state that I didn't go back in time to fix it, look at the time of my post and the time of your snapshot… Changes aren't going to magically appear in snapshots that were built 14-15 hours prior.



  • YES IT IS WORKING :)

    a. SaintPaul : thank you  for your suggestion

    I tried : 1.2.3-PRERELEASE-TESTING-VERSION
                built on Sat Mar 7 02:11:11 EST 2009

    and works fine

    b. cmb : thank you for your fix , I appreciate your efforts, concerning "Changes aren't going to magically appear in snapshots that were built 14-15 hours prior" , consider that Internet is Global and there is a term called "time difference" , the thing i did after reading your post in this thread was to test the latest available snapshot, sorry if i was misunderstood.



  • Thank you very much cmb.


Log in to reply