Gigabit WAN + SG-4860 - slow throughput



  • I have the 4860 and recently-installed Gigabit cable from Spectrum. Connected directly to the modem, I can get 940 mbps down/41 mbps up. Connected through the 4860, I'm lucky to get over 500 down (still can get 41 up). Running pfblocker on inbound-WAN outbound-LAN & Guest interfaces, DNSBL. Snort runs on LAN. System Activity doesn't show the 4 processors Idle drop below 80%.

    PowerD is set to Hiadaptive.

    I'm pretty sure the 4860 is supposed to support gigabit. Any help is appreciated!

    Thanks for any help!


  • Rebel Alliance Developer Netgate

    How does your WAN connect? DHCP? PPPoE? Something else?

    First, check Status > Interfaces and check for interface errors and see what the link speed/duplex is set to. I doubt you'll have a duplex issue at the speeds you are getting but it's worth a look.

    Next, disable snort, pfBlocker, etc and try it with just pfSense alone and see what you get. Adding more variables is not going to do anything but confuse the issue.



  • @jimp Thanks. I'm connected to WAN via DHCP (cable).

    I did try terminating the pfBlocker & Snort processes from the dashboard, and it had no impact in throughput. Do you think that was sufficient? I can of course completely disable them and see if that makes a difference.

    If it seems like a processor issue, I'll get the 5100, but seems like it might not do the trick since the CPU doesn't appear to be maxing out.



  • This post is deleted!


  • I'm able to get 950+mb on symmetric 1g fiber running pfblocker on a 4860. I would keep at the tinkering before pulling the trigger on a 5100.


Log in to reply