CARP failing for one VLAN



  • We have multiple VLANs with CARP enabled and they all work fine except for one. I've checked the interface IP / netmask settings, the VIP settings and the CARP settings and can't see anything wrong.

    Symptoms: CARP status on Master looks fine (all interfaces are shown as "MASTER", but on Secondary, Status for the interface is blank instead of "BACKUP". Please see screenshot below:

    screenshot

    Any ideas where I can look to see what's wrong?


  • LAYER 8 Netgate

    Look at the ifconfig output for that interface on both nodes and see what doesn't match. Post them both if you can.

    You might have a mismatch in interfaces between the nodes.



  • Thanks for the quick response Derelict! I tried to paste the output here but it gets flagged as spam so I can't post.

    Instead I've uploaded the image to dropbox and hope that works:

    ifconfig



  • I was able to resolve this with a reboot today. I had previously tried that but no success, so that's weird. Not sure what changed, but at least it's working now.


  • LAYER 8 Netgate

    Right. There was no CARP VIP on the secondary.

    A simple edit/save of that VIP on the primary should have taken care of it.

    Perhaps XMLRPC sync was not working/connected at the time that VIP was created or something else anomalous happened.


Log in to reply