IPV6 Setup and DHCPV6



  • A little context:

    I have IPv6 currently set up with DHCP6 enabled on my WAN (with 56 as the delegation size) and LAN set to Track Interface. DHCPv6 is disabled and Router Advertisements are set to Unmanaged and priority High. I have two IPv4 WANs and a couple of OpenVPN instances.

    Question 1: When I set two separate rules on my LAN, one for IPv4 to specifically my first IPv4 Gateway and another of IPv6 to specifically my IPv6 Gateway the results from test-ipv6.com come back all good:

    0_1536939831534_No Tunnel Mechanism.JPG

    However when I either specify the gateways as Default in those rules or combine them to a single rule (IPv4+6) I get a warning about using a tunnel mechanism:

    0_1536939885297_Tunnel Mechanism.JPG

    Rules (toggling enabled/disabled depending on what I'm testing):

    0_1536939955858_Rules Gateway.JPG

    Is this result from test-ipv6.com as expected? Am I missing some setting?

    Question 2: I'm trying to get a DHCPv6 server running. I enable DHCPv6 and change the Router Advertisements to Managed with DNS toggled to use same settings as DHCPv6 server.

    0_1536940403741_DHCPv6.JPG

    I get an IPv6 address assigned within the range specified but no traffic appears to pass. Pings to -6 addresses do not connect and test-ipv6.com reports no IPv6 address.

    Any suggestions as to why?



  • I believe I solved my Question 2... In my DHCPv6 settings I revised the Prefix Delegation Size to 56...

    Still Question 1... But I'm thinking that what I'm seeing is what is expected. Any response would still be appreciated.



  • Spoke too soon... It worked for a bit then stopped after I rebooted pfsense.


Log in to reply