Permit user Internet connections through pfsense Rules or SQUID



  • Hello,
    It would be very silly to ask this question, but i'm really newbie in pfSense and i'm deploying it in production network (as replacement for another firewall).
    I set a new virtual machine, and deployed pfSense with the same connections as my previous firewall. It does connect correctly to Internet, i've even been able to download SQUID package and check for latest version of pfSense (updated to 2.4.3 successfully).
    But now, there is no internet connection in user computer (the ip address is authorized in a rule for that).
    I only activated Squid proxy and enabled local cache.
    I would like to know now, how can i debug this?
    Thank you in advance.



  • Hello,
    Here is my network topology for more information about my network:0_1537188610684_TEST2.jpeg
    Which means that user computers are not on the same subnet as pfSense (i believe that installing SQUID proxy server is the solution for that)
    I believe too, FW1 is a router which has a leased line internet connection. and has static Nat to pfSense.
    And pfSense, is correctly reaching Internet. I just updated to the latest version (2.4.3.1).
    Any help please??
    Regards



  • Hello,
    I would like to inform you that my problem was resolved. What was missing is adding the subnet of PC to the allowed subnets in SQUID Proxy Server.
    Thank you.


Log in to reply