NTP status on Dashboard



  • Here using a GPS / PPS for time sync configured a few years back. Always working except for:

    Dashboard

    Dashboard always shows internet time servers

    0_1537363424491_gps2.jpg

    except during a network outage.

    0_1537363453212_gps.jpg

    How can I change the Dashboard status to indicate primary time if from GPS?

    I thought having configured the hardware GPS NTP that it would show up on the Dashboard.


  • LAYER 8 Global Moderator

    If you setup a ntp server and check that it is preferred, then that is what it would prefer to use ;)



  • Thank you johnpoz.

    I have it set as the preferred NTP server. It is on the top of the list here. Is there anything I have to do to show this on the Dashboard NTP widget?

    0_1537369361907_preferredNTPServer.jpg

    0_1537369378720_preferredNTPServer1.jpg


  • LAYER 8 Global Moderator

    you have pool set as prefer as well. Prob uncheck pool as preferred if you have gps/pps setup.



  • Thank you John.

    Unchecked the pool set as preferred. It still did not show up on the Dashboard.

    Removed all references to NTP servers except for the GPS and checked Localization and now the GPS/PPS shows up on the Dashboard.

    Guessing here will be fine as I have not used the internet for time in many many years now and it will not break PFSense to do this.

    0_1537375912088_preferredNTPServer3.jpg


  • LAYER 8 Global Moderator

    Lack of ntp is never going to break anything ;) I run stratum 0 on a pi with gps.. But it really sync time from other ntp over internet.. Since this is better than gps - to get to what second it is.. Then the pps keeps the actual time accurate..

    pi@ntp:~ $ ntpq
    ntpq> pe
         remote                                   refid      st t when poll reach   delay   offset   jitter
    =======================================================================================================
    *SHM(1)                                  .PPS.            0 l   43   64  377   0.0000  -0.2993   0.2656
    xSHM(0)                                  .GPS.            0 l   17   64  377   0.0000 -112.964   1.1096
    -ntp.your.org                            .CDMA.           1 u   23   64  377  36.9462  14.0866   3.2599
    +173-161-33-165-illinois.hfc.comcastbusi .GPS.            1 u   17   64  377  28.9041  -1.6801   2.0913
    +tock.usshc.com                          .GPS.            1 u   76   64  366  18.7285   2.0356  24.6235
    

    Notice GPS is marked X...



  • Thank you John.

    So do you see the GPS in the Dashboard?

    Checking here now only see the GPS in ntpq where as before pps, gps and internet NTP servers...

    /root: ntpq
    ntpq> pe
         remote           refid      st t when poll reach   delay   offset  jitter
    ==============================================================================
    oGPS_NMEA(0)     .GPS.            0 l    -   16  377    0.000    0.003   0.026
    ntpq>
    

    Maybe I should switch it back?

    Switched it back..thinking it takes a bit for PPS to come up (was seeing it before)

    ntpq> pe
         remote           refid      st t when poll reach   delay   offset  jitter
    ==============================================================================
    *GPS_NMEA(0)     .GPS.            0 l   12   16    1    0.000    0.028   0.000
     0.pfsense.pool. .POOL.          16 p    -   64    0    0.000    0.000   0.000
     23.134.96.254   252.74.143.178   2 u    1   64    1   41.763    0.186   1.522
     eterna.binary.n 204.9.54.119     2 u    -   64    1   28.596    3.498   2.029
     ntp2.wiktel.com 212.215.1.157    2 u    1   64    1   29.253    9.657   1.283
     45.32.75.249 (4 142.66.101.13    2 u    -   64    1   65.164    2.326   1.400
    ntpq>

Log in to reply