System is hung up, busy doing something and web GUI won't respond



  • It had been working fine, great actually, I had just completed some configs a couple of days ago and I still hadn't saved a backup because I was in a roll and got cocky. :(

    Anyway, restarting the web server won't solve it, the GUI hangs after logging in. I went into PHP from the options in the menu, and found a command to restart yet again the GUI but nope.

    The machine is consuming nearly all of its resources, see here,
    0_1537487799689_Screen_Shot_2018-09-20_at_17_54_26.png

    Then selected the shell option and invoke top to see what's going on and it turns out it is quite busy, I just didn't want to believe the hypervisor 'cause it averages stuff and something's it way off.
    0_1537487823668_Screen Shot 2018-09-20 at 17.56.52.png

    What if I run "pfctl -d" that disables the filtering/firewall, right?? If I do that would it kill them since it would no longer need to filter and give me enough CPU time to log in and poke around?

    I checked the history of last modifications and I'm not sure going back the whole 30 would do me any good. I already went about 20 back just now and didn't change at all.

    Thanks guys!



  • By the way, I realize this was happening 'cause websites were hanging, after restarting the GUI a couple of times I restarted the firewall and the websites aren't hanging anymore but the firewall still is. :/



  • Hi,

    Do this :
    Make a config backup.
    Then, goto console mode and blow away the config, go back to the initial setup, and make your WAN work.

    Check if everything works fine.
    Compare your last saved backup with the new situation (compare the backup file, they are readable with a simple editor like notepad++).
    Import parts of the saved backup into your system.
    When things go back, you know where the issue is situated.

    Also : you have console access : use option 8 and kill these "*pf ru" instances.

    Btw : never used a VM myself so can't help you with issues related to pfSense running in VM.

    edit : @umademelosemyusernamepfsense : You are making reference of the fact that you can't use the login user name of the 'old' pfsense forum ? That was solved, it was actually never a problem ... as long as you remember what was the login name for the pfsense forum ☺ and you remember what was the related email address ..... ☺
    If not, change to the more appropriate @memademelosemyusernamepfsense ;)


  • Netgate Administrator

    What is that firewall actually doing? Or supposed to be doing?

    Steve



  • What version of pfsense are you using?


Log in to reply