/boot/loader.conf lots of duplicate comconsole_port="0x2F8" lines



  • I was just poking around and saw in my /boot/loader.conf a lot of duplicate lines. I guess this happened during some botched updates? This is an SG-4860 on factory image updated to 2.4.4.r.20180918.1800)

    kern.ipc.nmbclusters="1000000"
    kern.ipc.nmbjumbop="524288"
    kern.ipc.nmbjumbo9="524288"
    zfs_load="YES"
    comconsole_port="0x2F8"
    comconsole_port="0x2F8"
    comconsole_port="0x2F8"
    comconsole_port="0x2F8"
    comconsole_port="0x2F8"
    comconsole_port="0x2F8"
    comconsole_port="0x2F8"
    comconsole_port="0x2F8"
    comconsole_port="0x2F8"
    comconsole_port="0x2F8"
    comconsole_port="0x2F8"
    comconsole_port="0x2F8"
    comconsole_port="0x2F8"
    comconsole_port="0x2F8"
    comconsole_port="0x2F8"
    boot_serial="YES"
    console="comconsole"
    comconsole_speed="115200"
    comconsole_port="0x2F8"
    hint.uart.0.flags="0x00"
    hint.uart.1.flags="0x10"
    autoboot_delay="3"
    hw.usb.no_pf="1"
    

    I assume this should be edited and changed to the below. Should any other lines be removed or changed?

    kern.ipc.nmbclusters="1000000"
    kern.ipc.nmbjumbop="524288"
    kern.ipc.nmbjumbo9="524288"
    zfs_load="YES"
    boot_serial="YES"
    console="comconsole"
    comconsole_speed="115200"
    comconsole_port="0x2F8"
    hint.uart.0.flags="0x00"
    hint.uart.1.flags="0x10"
    autoboot_delay="3"
    hw.usb.no_pf="1"
    

  • Netgate Administrator

    Yes, indeed. It only needs one comconsole_port="0x2F8" line.

    That was a known bug and is now fixed in what will be 2.4.4 release.

    Steve



  • Perfect, thanks!


Log in to reply