pfSense build with problems with Intel S1200KPR



  • Hi.
    I have run pfSense for many years now on some old consumer grade hardware, I decided to "upgrade" my hardware to some more server grade hardware.

    I got my hands on:
    MB: Intel S1200KPR
    CPU: Intel Xeon E3-1225v2
    Ram: Corsair ValueRam 4GB (I'm waiting for an 8GB stick of Samsung ECC UDIMM to come in the mail.)
    PSU: Corsair CX600M
    Case: Fractal Node 304
    NIC: Intel 4Port Gigabit PCI-Ex4

    So, to my problem. I can not get the motherboard to boot from any hdd after I install pfSense on it. I have tested 4 different hdd's and the same problem.
    No matter what boot option I choose, I still get "No boot device found".
    I also tried to install Ubuntu 18.10, and FreeNAS 11.01 and both of these boots without any problem.

    So my question is: Is there anyone of you who have gotten pfSense to work on this board?

    Any help or suggestions would be appreciated.

    /Anders


  • Banned


  • Netgate Administrator

    I hit a problem on a similar age board to that which exhibited just like that.

    Effectively the installer is booted using a different boot method than the HD is set to (UEFI or legacy BIOS) and the default guided UFS install will install the same method it booted from.

    Try using the Guided ZFS install in the installer. Make sure the partition scheme is set to 'UEFI + BIOS'. That should boot the HD however the USB stick is booted.

    Steve



  • @stephenw10
    I tried both the UFS and the ZFS auto options, and both of them resulted in the same :S

    I read up on the link @Grimson posted and of course the one thing I had not tried solved it.
    I used "gpart set -a active" on both the mirrored drives and now it boots fine!.

    Thank you both for the quick replies and the help :D



  • Similar thing happens on the Intel S1200BTL, BTS boards. Use UEFI instead of Legacy that solves the issue.


Log in to reply