IGMP Proxy not working after upgrade to 2.4.4



  • Hi,

    after upgrade from 2.4.3-p1 to 2.4.4 IGMP Proxy is not working anymore:

    Error from log:

    igmpproxy[65102]: There must be at least 1 Vif as upstream.
    

    After installing the binary from the 2.4.3 ISO, IGMP Proxy is working again.
    It seems the new version cannot handle PPPoE Interfaces. :(

    My config:

    ##------------------------------------------------------
    ## Enable Quickleave mode (Sends Leave instantly)
    ##------------------------------------------------------
    quickleave
    phyint pppoe0 upstream ratelimit 0 threshold 1
    altnet xxx.xxx.xxx.xxx/dd
    altnet xxx.xxx.xxx.xxx/dd
    altnet xxx.xxx.xxx.xxx/dd
    
    phyint re1.200 downstream ratelimit 0 threshold 1
    altnet yyy.yyy.yyy.yyy/dd
    
    phyint re0.400 disabled
    phyint re2 disabled
    phyint re0.50 disabled
    

  • Rebel Alliance Developer Netgate

    So the same configuration works, the only difference is the binary?

    There may be a patch that didn't get carried forward, or maybe it failed to apply and was removed. Hard to say. I don't remember anything specific there, though. Open an issue at https://redmine.pfsense.org/ with a 2.4.4-p1 target and we'll try to have a look at it.

    I don't think anyone around here has even tried IGMP proxy on PPPoE.



  • Yes, same configuration, binary from 2.4.3 works and binary from 2.4.4 does not want to work.

    I will open an issue.

    Thx! :)