Installations hangs with PER6 HW RAID card, can we disable the loading of the megaraid driver?



  • Hi,

    We have a rather odd problem.
    When we try to install pfsense 2.4.3 on our server it stops after it has loaded the MegaRaid lsi driver.

    We have configured the card with 1 virtual drive and the installer finds the drive as seen when first booting and listing attached drives (and so does linux and other oses).

    However when starting the install it tries to load the megaraid driver and then it "hangs". It is the same behaviour on freebsd but all other oses we tried works.

    I suspect this is becasue freebsd tries to "take over" the raid card for some reason.
    We have tried to disable the megaraid "module" but it seams to built into the kernel and whatever command we tried to disable the driver failed.

    In short I have two questions, can we disable the driver with the current build or do we need to rebuild the kernel (without support for the megaraid driver ?
    And related why is this driver necessary at all as the disks will present themselves as "bios" disks, ie if we do not load the driver will the install not detect the virtual disk at all?

    Best regards
    Jonas



  • The "virtual disk" is still connected to a "real" controller. And the OS needs a driver for that controller.



  • Sorry for being a bit stupid but the disk is detected in all other oses as well as shown in startup of the freebsd/pfsense boot AFAiK without any raid driver loaded. E.g. I am pretty sure my usb freedos installation does not have the drivers for the raid card and they can see and "mount" the virtual disk.

    I can understand that you need the driver if you want to control the raid card, ie override the settings or have direct access to the physical disks but that is clearly not what I want in this scenario.

    Anyway, this is a deal breaker and if there is no workaround for this I need to use a different product so it is rather crucial to get this step working.
    I did read on the net that flashing the card into IT mode and let freebsd handle the physical disks could solve this problem but I do not, in this case, under any circumstances want to use software raid (or what the bsd term is for the same).



  • Do you have on-board SATA ports? If so, just attach an SSD and pull the PERC out.

    Or maybe boot to a USB device. pfSense doesn't need very much disk space.



  • While we both have sata and USB neither will suffice (single point of failure). Of course we could do software raid over multiple USB or SATA drives but then we need to take the server down if a disk fails which is not an option (with the raid card we have configured a RAID 1 with 4 spare drives so basically 5 drives can fail before "shit hits the fan").

    The server also has a flash card so we have been evaluating the "nano" installation where the writes to the disk is reduced. However, for the latest version of pfsense I cannot find that install method available (is support for that installation method removed ?)

    I guess next step is that we need to recompile the freebsd kernel to try to fix this or as a last alternative move on to non freebsd based products.

    Thanks for the inputs so far.



  • You should probably be talking to the FreeBSD folks, since this seems related to the underlying OS, not pfS.

    https://www.freebsd.org/community.html

    As a workaround, perhaps you could replace the PERC6 with something else?