Please Help With "Unidentified Network"



  • This problem is weird and I've exhausted internet searches.

    I'm using the latest version of pfSense. I have CenturyLink gigabit fiber to the home. I previously used an Actiontec router when I had two Windows 10 Pro machines with private static IPs. Everything worked. I then swapped out the Actiontec router with a machine running pfSense. Everything worked. I have since built two more Windows 10 Pro machines. When I connect them using DHCP, everything works. When I then assign each of these new machines their own private IPs, everything works until I reboot either computer. After a reboot I get "Unidentified Network" and both machines are forced in a public network profile. This doesn't happen with the original two Windows 10 Pro machines. I can reboot them with their static IPs and they will remain on "Network" or "Network 2" and each have a private network profile. As an experiment, I swapped the Actiontec router back in, and then all four machines work fine. I can't figure out any settings in pfSense that might be affecting just the two new computers.

    After complete frustration, I've started wondering if the NICs or NIC drivers in each new computer could be the problem. Both new machines have onboard motherboard NICs. One computer has "Intel (7) I219-V". The other has "Intel (2) I219-V". I don't know why the numbers are different in the parentheses, but I think they have the same NICs. Both of the older computers have diffenent mobo NICs.

    Does anyone have any ideas what is wrong? I've read about Powershell and registry hacks to force a private network, and about changing the network location local security policy, but most of these hacks do not survive a reboot. I'm at a loss. :(