System Update no longer show 2.3.5



  • I switched the System / Update / System Update from 2.3.5 (Latest Stable (version 2.3.x) to Latest Stable (version 2.4.x).

    Now I can't go back to 2.3.x ... only 2.4 are showed.

    In Diagnostics / Backup & Restore / Config History is see that change.

    -		<pkg_repo_conf_path>/usr/local/share/pfSense/pkg/repos/pfSense-repo-legacy-23.conf</pkg_repo_conf_path>
    +		<pkg_repo_conf_path>/usr/local/share/pfSense/pkg/repos/pfSense-repo.conf</pkg_repo_conf_path>
    

    I tried to revert the config, reboot, but it still doesn't offer 2.3.x. This is because the pfSense-repo-legacy-23.conf is no longer present on the system.

    I disable the Disable the automatic dashboard auto-update check for now, but the Package Manager is unusable as it now offer 2.4.4 packages that might create problems on 2.3.5.



  • 2.3.5 is EOL very soon: https://www.netgate.com/blog/pfsense-release-2-3-x-eol-reminder.html

    So update to 2.4.4.



  • I know that. I will probably update to 2.4.4 in the near future.

    But the pfSense-repo-legacy-23.conf should remain available and present on the system to prevent system problems if an unaware user update a package from the wrong base.


  • Netgate Administrator

    If you did try to install a package it should fail before actually installing anything as they all have php7 as a dependency which won't be met.

    >>> Setting vital flag on lang/php56... done.
    WARNING: Current pkg repository has a new PHP major
             version. pfSense should be upgraded before
             installing any new package.
    Failed
    

    Steve



  • @stephenw10 I didn't try but it's good to know it would not break anything.