The DNS Resolver is disabled or stopped.



  • After upgrade to pfSense 2.4.4-RELEASE (amd64), browser pages not loading - seems like bad DNS. If I manually add a DNS server to network settings instead of allowing the DHCP setting of 192.168.1.1, it works. Also, in Status —> DNS Resolver, message in the banner says “The DNS Resolver is disabled or stopped.” The service will not start when I click the start button. If I go to Services/DNS Resolver/General Settings, enabled is checked. When I click Save I get “The following input errors were detected:
    • The generated config file cannot be parsed by unbound. Please correct the following errors:
    • /var/unbound/test/unbound.conf:102: error: syntax error
    • read /var/unbound/test/unbound.conf failed: 1 errors in configuration file

    I had earlier followed “Configuring QUAD9 on pfSense” https://www.linuxincluded.com/configuring-quad9-on-pfsense/" and it was working PERFECTLY. The above just started.

    Thank you.



  • Remove anything you have in the custom options and then paste it in a notepad doc for safe keeping. Save and see if you can get unbound to restart. Start adding back the custom options and saving in between. I've seen a few times where something "extra" is added even though the text looks the same.



  • Thank you for replying and so fast. Removing the "custom options" worked immediately and I was able to save the config without an error message restart the service - immediately solved my inability to "surf" which was my first hint I had a DNS issue.

    Secondary problem is it fails to save (I get an error message upon trying to save) immediately upon entering my first line into custom options: log-replies: yes

    Tried it again by adding back JUST my 2nd line: forward-zone:

    Similar error message. Can I NOT have custom options configured? Thanks.



  • For many of the custom options, you need to specify the "server:" directive first. You only need to specify the directive one time. The in's and out's of its usage are discussed briefly in same guide -- https://www.linuxincluded.com/configuring-quad9-on-pfsense . Hope that helps!



  • WORKED PERFECTLY! Went back and looked and I don't know how that line "server:" was disappeared from my options field but it was and I put it back and all working perfectly! I can't thank you enough.



  • Excellent! Happy to help!