Upgrading SG-2220 from 2.3.x to 2.4.x



  • I have a SG-2220 running for over 3 years now, and I noticed it won't show me new updates on the dashboard. As I found out, this is because it is running the i386 version, which is no longer supported. The CPU is 64Bit, so reinstalling the 2.4 version manually should be an option.

    Is there a how-to somewhere which would guide me through the process of manually reinstalling pfsense on the SG-2220?





  • Thanks. I've opened a support ticket to obtain access to the software image, and then proceed to reinstall the software.


  • Rebel Alliance Developer Netgate

    The ADI images necessary to install on the SG-2220 were never offered in 32-bit, so I'm not quite sure how you would have ended up in that position. Are you certain it's an SG-2220?

    If indeed it is running 32-bit, then your best option would be a completely fresh installation. You can either contact support for the factory firmware, assuming it's an SG-2220, or use a CE memstick to reinstall. If it needs CE, and it really is an SG-2220, then use the ADI memstick.



  • 100% sure. I still have the shipping info mails from the online order, the box looks like this: https://store.netgate.com/SG-2220.aspx And the hardware shown in the pfsense dashboard matches the hardware in the SG-2220 technical description.

    I already contacted customer support and received the link for the software image, so I will try my luck with a fresh install vial USB stick.


  • Rebel Alliance Developer Netgate

    OK. I did find where for only one version (2.2.3) we did put up CE i386 for ADI but they still all shipped with amd64 installed. It's possible that back in the 2.2.x days you restored a configuration to the 2220 that had a hardcoded 32-bit update URL. It's possible that from there it unintentionally switched you to i386.

    But now the only way to fix it is a reinstall. Thankfully it's super simple and you can even have the 2.4.x installer pick up the old config during the installation process: https://www.netgate.com/docs/pfsense/backup/automatically-restore-during-install.html#recover-config-xml



  • Okay, I downloaded the image, flashed it onto my USB stick, and tried to boot the SG-2220 off of it, however it will refuse to boot from the stick. It will always just boot from internal storage into my 2.3.x installation.

    How can I force it to boot from USB?


  • Rebel Alliance Developer Netgate

    I don't have that model here to check but on the older BIOS I think you had to hit F12 at boot during POST and then pick the USB drive from the menu.

    Also, make sure it isn't a USB 3 drive.

    If that still doesn't work, ping the support crew at https://go.netgate.com and someone can clear up the procedure for that hardware. Be sure to include which BIOS revision you have, it should show on the dashboard and during the boot sequence.



  • Ok I see, its a pretty new USB-Stick with 64GB and USB-C as well as USB-A, so maybe i'd pick a different stick then. I'm not sure though if I still have a non-USB3 one.



  • Okay it seems like I am unable to get this to work. I've flashed the image onto my old WD 80GB USB HDD (wd800u017), which according to my research is USB2-based.

    Yet I am unable to get the box to boot from USB. When connecting the serial console (screen /dev/tty.SLAB_USBtoUART 9600 as I am on mac) first shows garbage characters, then after some seconds the boot menu of the existing installation pops up.
    See https://imgur.com/a/NIUhK4c

    I tried pressing F12 over and over, without a change. Also, before the boot menu appears, I cannot "see" anything (I only see those garbage characters), so even if I would be triggering the boot menu, I could not see it.

    According to https://www.netgate.com/docs/pfsense/solutions/sg-2220/connect-to-console.html I also tried the speeds 112500 and 38400, where 38400 completely shows garbage and no readable characters, and 112500 shows the same as 9600 (first garbage, then boot menu).

    [edit] As advised I've just opened a ticket @ go.netgate.com



  • Did you ever get this resolved?

    screen /dev/cu.SLAB_USBtoUART 115200 works for me on macOS.



  • @goodthings said in Upgrading SG-2220 from 2.3.x to 2.4.x:

    115200

    Yes, indeed after using 115200 as advised by the technical support I was able to get it to work. I just confused 115200 with 112500 in my attempts.