[SOLVED] Dual 10/100/1000 Intel 82573L Auto Negotiate Issue have to force 100mb



  • Hello.
    I am having an Issue with my Dual 82573L NICs. On my WAN Port my NIC will auto detect that it should connect to my Cable Modem on a 100mb connection, which is what it should do. However my connection speed is really slow and I have really high pings to any external IP.

    Over the past week I found out that if I force the NIC to connect to my modem at 100mb my connection quality is restored. For example every time the router reboots I have to issue a command like: ifconfig em1 media 100baseTX mediaopt full-duplex

    This will force my WAN NIC to connect at 100mb even though it auto connects at that speed. I don't know how or why it helps my connection quality but it really does. (could someone explain)

    What I need help on is how to run this command at startup.

    (I put this is the hardware cat because it is a hardware issue and I would like to know why)
    ![ifconfig readout.jpg](/public/imported_attachments/1/ifconfig readout.jpg)
    ![ifconfig readout.jpg_thumb](/public/imported_attachments/1/ifconfig readout.jpg_thumb)



  • Has anyone else found that their internet connection was really slow behind pfsense but when they connect their PC directly to the modem you have really fast download and upload speeds?

    Can someone shed some light on this?



  • Some people have reported this with Squid in the past.

    Of course, you don't say what version of pfSense you're running, which makes it hard to comment.  I'd also point out that you can force network card settings - details lurk in the forum somewhere.  That might help you (as the screenshot you post shows it autonegotiating at half-duplex.  Sticking a 100 Mb switch in the way might help.



  • Yes. Thank you for the help. Its running pfsense 1.2.2 the latest stable release. I will try putting a 100mb switch in between the two and see if that helps. I was able to find how to change the network speed setting in config.xml to keep the changes when I reboot it. That seems to fix it for now.



  • Okay, so I put a 100mb hub in between the modem and the firewall. Didn't do anything. I also tried a 100mb switch.
    When I test my connection on speedtest.net when connected directly PC to modem I get 2300 down and 500 up. When I have the modem connected to the firewall I get 700 down and 330 up.
    I conducted this test with a new install of pfsense 1.2.2 with no addons and nothing extra enabled. Right out of the box. I just ordered a PCI riser card so I can try a different NIC on the WAN.



  • I was able to fix it by one of two things.
    Forcing the NIC to 100mbps seemed to work okay. It would flake sometimes. And using a 100mbps NIC also works, which seems to work the best out of the two solutions.

    I don't think its an issue with pfsense, its the modem that doesn't play nice with the card. Thank you for your help.


Log in to reply