Lost internet after in-place upgrade from 2.4.2 to 2.4.4



  • After in-place upgrading to 2.4.4. I lost access to the internet. I am running in a VM so I restored the previous version I was running (2.4.2).

    Below are the boot-up logs for 2.4.4 (masked out IP addresses with xxx). Anyone have any suggestions on what may be wrong? On the dashboard, the WAN and LAN interfaces are green; but even PFSense can't reach the internet (packages can be retrieved or updated; pings timeout). I temporarily disabled the firewall and that did not correct anything so I am assuming something else is broken in the configuration.

    I tried restoring the config from 2.4.2 but it didn't help (again no internet; packages failed to update).

    Sep 29 11:18:47 kernel ovpns1: link state changed to UP
    Sep 29 11:18:47 kernel tun2: changing name to 'ovpns2'
    Sep 29 11:18:47 check_reload_status rc.newwanip starting ovpns1
    Sep 29 11:18:47 kernel ovpns2: link state changed to UP
    Sep 29 11:18:47 check_reload_status rc.newwanip starting ovpns2
    Sep 29 11:18:47 kernel pflog0: promiscuous mode enabled
    Sep 29 11:18:48 sshd 75514 Server listening on :: port 22.
    Sep 29 11:18:48 sshd 75514 Server listening on 0.0.0.0 port 22.
    Sep 29 11:18:48 php-fpm 335 /rc.newwanip: rc.newwanip: Info: starting on hn0.
    Sep 29 11:18:48 php-fpm 335 /rc.newwanip: rc.newwanip: on (IP address: 24.xxx.xxx.202) (interface: WAN[wan]) (real interface: hn0).
    Sep 29 11:18:48 php-fpm 334 /rc.newwanip: rc.newwanip: Info: starting on ovpns1.
    Sep 29 11:18:48 php-fpm 334 /rc.newwanip: rc.newwanip: on (IP address: 192.168.8.1) (interface: []) (real interface: ovpns1).
    Sep 29 11:18:48 php-fpm 335 /rc.newwanip: rc.newwanip: Info: starting on ovpns2.
    Sep 29 11:18:48 php-fpm 335 /rc.newwanip: rc.newwanip: on (IP address: 192.162.9.1) (interface: []) (real interface: ovpns2).
    Sep 29 11:18:45 php-cgi rc.bootup: Gateway, NONE AVAILABLE
    Sep 29 11:18:45 php-cgi rc.bootup: Gateway, none 'available' for inet6, use the first one configured. ''
    Sep 29 11:18:45 php-cgi rc.bootup: sync unbound done.
    Sep 29 11:18:45 kernel done.
    Sep 29 11:18:45 kernel done.
    Sep 29 11:18:46 rc.gateway_alarm 93777 >>> Gateway alarm: WAN_DHCP (Addr:24.xxx.xxx.1 Alarm:1 RTT:15.455ms RTTsd:6.954ms Loss:33%)
    Sep 29 11:18:46 check_reload_status updating dyndns WAN_DHCP
    Sep 29 11:18:46 check_reload_status Restarting ipsec tunnels
    Sep 29 11:18:46 check_reload_status Restarting OpenVPN tunnels/interfaces
    Sep 29 11:18:46 check_reload_status Reloading filter
    Sep 29 11:18:46 kernel done.
    Sep 29 11:18:46 php-cgi rc.bootup: NTPD is starting up.
    Sep 29 11:18:47 check_reload_status Updating all dyndns
    Sep 29 11:18:47 php-fpm 334 /rc.dyndns.update: phpDynDNS (xxx): No change in my IP address and/or 25 days has not passed. Not updating dynamic DNS entry.
    Sep 29 11:18:47 kernel .....done.
    Sep 29 11:18:48 php-fpm 983 /rc.dyndns.update: phpDynDNS (xxx: No change in my IP address and/or 25 days has not passed. Not updating dynamic DNS entry.
    Sep 29 11:18:48 php-fpm 334 /rc.dyndns.update: phpDynDNS (xxx): No change in my IP address and/or 25 days has not passed. Not updating dynamic DNS entry.
    Sep 29 11:18:49 php-fpm 983 /rc.dyndns.update: phpDynDNS (xxx): No change in my IP address and/or 25 days has not passed. Not updating dynamic DNS entry.
    Sep 29 11:18:51 php-cgi rc.bootup: Creating rrd update script
    Sep 29 11:18:51 syslogd exiting on signal 15
    Sep 29 11:18:51 syslogd kernel boot file is /boot/kernel/kernel
    Sep 29 11:18:51 kernel done.
    Sep 29 11:18:52 kernel done.
    Sep 29 11:18:52 php-fpm 335 /rc.start_packages: Restarting/Starting all packages.
    Sep 29 11:18:53 login login on ttyv0 as root
    Sep 29 11:18:58 rc.gateway_alarm 75096 >>> Gateway alarm: WAN_DHCP (Addr:24.xxx.xxx.1 Alarm:0 RTT:9.951ms RTTsd:3.015ms Loss:7%)
    Sep 29 11:18:58 check_reload_status updating dyndns WAN_DHCP
    Sep 29 11:18:58 check_reload_status Restarting ipsec tunnels
    Sep 29 11:18:58 check_reload_status Restarting OpenVPN tunnels/interfaces
    Sep 29 11:18:58 check_reload_status Reloading filter
    Sep 29 11:18:58 php-fpm 983 /diag_reboot.php: Successful login for user 'admin' from: 10.0.1.78 (Local Database)
    Sep 29 11:18:59 php-fpm 983 /rc.openvpn: Gateway, NONE AVAILABLE
    Sep 29 11:18:59 php-fpm 983 /rc.openvpn: Gateway, none 'available' for inet6, use the first one configured. ''
    Sep 29 11:18:59 php-fpm 983 /rc.openvpn: OpenVPN: One or more OpenVPN tunnel endpoints may have changed its IP. Reloading endpoints that may use WAN_DHCP.
    Sep 29 11:18:59 php-fpm 335 /rc.dyndns.update: phpDynDNS (xxx): No change in my IP address and/or 25 days has not passed. Not updating dynamic DNS entry.
    Sep 29 11:19:00 php-fpm 335 /rc.dyndns.update: phpDynDNS (xxx): No change in my IP address and/or 25 days has not passed. Not updating dynamic DNS entry.



  • Looks like there were some disabled gateways that I am guessing were being applied. I deleted them and the internet came back.

    Probably similar to this issue:
    https://forum.netgate.com/topic/135903/2-4-4-gateway-issue