Sierra Wireless EM7565 not responding



  • Hello everyone!

    I'm in the middle of building my new pfSense router with the EM7565 LTE-A Module (used pfSense in a VM with the provider supplied router with bridge firmware until now).

    Windows Part:
    I was able to flash the latest Firmware (SWI9X50C_01.07.02.00) onto the Module and it is working fine with Windows 10 and Sierra Skylight Connection Manager.
    I was able to open a Serial Connection to the Module on COM4 (COM3 & COM5 were also created, but are not responsive)
    Looked like this in the Windows Device Manager:

    • COM3 => NMEA Port
    • COM4 => WWAN Modem
    • COM5 => DM Port

    Everything responded fine and the AT commands were being handled.
    Successfully switched to MBIM using "AT!USBCOMP=1,3,1009", but I later found out, that this is not permanent and will reset on reboot.

    Now to the pfSense Part
    I installed pfSense 2.4.4-RELEASE and used a dummy WAN-Port for the initial setup.
    Then I tried to setup PPP, but i only got this messages (/dev/cuau0 and /dev/cuau1 do the same thing).
    The System-Log of PPP is this:
    0_1538260684504_ppp-log.JPG

    Continuing to the console...
    First thing first, look into the usbconfig for the Card:
    0_1538260426319_usbconfig-dump.JPG
    Device is visible.. hurraayy! But wait... manually writing to device doesn't work! Opening the Connection works, but then I get stuck indefinitely!
    0_1538260661943_ppp.JPG
    OK... more googling! Uhh whats that? Wrong bootup as Mass Storage Device!
    0_1538260919094_camcontrol.JPG
    and NOPE! atleast not vialable with camcontrol!

    Finally a pointer in the right direction!
    usb_modeswitch sounds promissing! Installed it right away... but configuring it is a different task.
    Let's try Sierra-Mode:
    0_1538261353358_usb_modeswitch.JPG
    NOPE again...

    How you can help me
    Has anybody got experience with the EM7565 or EM75XX-Series running on pfSense and maybe encountered a similar issue?
    Does anybody have a EM7565 profile for usb_modeswitch that works?
    Is it somehow possible to force a different boot mode using AT commands (before switching to pfSense)?
    Or a general pointing in a further direction is also appreciated!

    My new Router/Firewall
    Mainboard, 4GB RAM, 32GB SSD, i5-5300
    WWAN-Module and M.2 to miniPCIe-Adapter
    Provider-Info:

    • Provider: three (drei) Austria
    • Plan: HuiFlat150

    That's it, I hope you have some Ideas!
    Thank you in advance!

    Kind regards,
    Marcel


  • Netgate Administrator

    Before you can talk to the card usingt AT commands in FreeBSD/pfSense it will need to be seen as a serial device.
    The two ports you see there, cuau0 and cuau1, are the standard com ports in the system. You need to see USB connected serial ports such as cuaU0. Those are usually created by u3g but it looks like that card is too new to have appeared in the device list yet.
    https://github.com/pfsense/FreeBSD-src/blob/021c0c7c1ad07dad2227fb7529e176648cc53716/sys/dev/usb/usbdevs#L4046

    Some of those devices can have their product ID set, in which case you might try 0x9071. That is not without risk though as reverting that change might be an issue.

    I have used the EM7355/7305 and the EM7455 successfully. However they are limited in throughput due to the ppp connection. I believe 42Mbps is the theoretical maximum.

    Steve



  • Thanks for the fast response!

    ohh, I thought that cuau0 and cuaU0 were the same (depending on version of the OS)!

    Changing the Product ID to 0x9071 using usb_modeswitch doesn`t work and gives the same error as above.
    Command: usb_modeswitch -v 0x1199 -p 0x9091 -P 0x9071 -S

    The throughput should be much higher than that!
    I've found this speedtest on an primary german forum here.

    pic
    But this guy is using OpenWRT instead of pfSense, so am I maybe forced to switch to OpenWRT?

    Have a great day!
    Marcel


  • Netgate Administrator

    Yes, the upper case U denotes a USB connected device.

    USB mode switch may not be able to change that. I expect to ahve to change it using AT commands in Windows but you said the USB composition was not maintianed across power cycles so that might not be possible either.

    The throughput is limited by the ppp interface that FreeBSD has to use. There is nothing we can do about that. Except maybe port the umb(4) driver from OpenBSD. 😉

    Steve



  • Ok, then I have to wait until pfSense gets some updates and supports my card.

    In the mean time I installed Lede/OpenWRT, it works great and was easy to install using many tutorials written for this card.

    {ENG} How to install Lede on x86
    {GER} Configuration for EM/MC Modules
    {GER} Bringing the module to MBIM mode

    Thank you for your support Steve!
    I will return to pfSense as soon as it gets support for my card, don't worry :)

    -Marcel