Shared object "libssl.so.8" not found, required by "pkg"



  • I am trying to upgrade from NanoBSD 2.3.5 to full BSD 2.4.4, following the instruction on https://www.netgate.com/docs/pfsense/install/upgrading-64-bit-nanobsd-2-3-to-2-4.html

    After using the web interface to

    • clone the boot partition s2 to s1,
    • switch from boot partition s2 to boot partition s1 and
    • reboot,

    I noticed that:

    • webconfigurator would not start automatically
    • when trying to use the command pkg, I get the error: Shared object "libssl.so.8" not found, required by "pkg"

    I tried to find that library in any partitions, but it is not there, not in /dev/ada0s1a nor in /dev/ada0s2a.

    But I have /usr/lib/libssl.so.7

    So, something when wrong with the linker when cloning the boot partition?

    Before going any further, I terribly need some help.

    Thanks in advance,

    Olivier



  • After some poking around, going back to boot partition ada0s2a, rebooting, problem is the same.

    I had made a copy of / on some spare space on the SSD. I changed /usr/local/share/pfSense/pkg/repo/pfSense-repo.conf to point to url: "pkg+https://pkg.pfsense.org/pfSense_v2_3_5_xxx and I did a pkg-static bootstrap -f and it seems the problems are solved:

    • pkg is working
    • nginx is starting at boot time

    How can I make sure nothing else is messed up in my installation?

    Thanks in advance,

    Olivier