VLANs not working with TP Link Easy Smart Switch V4



  • I read through and watched a lot of tutorials on youtube on how to do this but it still isn't working.
    I got 1 cable coming out from pfSense router to the managed switch on port 1, and I got 3 other VLANs to use. Setup on pfSense and DHCP enabled.
    On the switch I got VLAN q option used and setup with the same VLAN id as on pfsense (10 for DMZ, 20 for PC and 30 for WIFI). I went and set the PVID for every port I use the same as the VLAN id like this:
    VLAN 1: All ports untagged (cannot be deleted, only changed to tagged as it is locked like that on the TP Link switch)
    VLAN 10: Port 1 & 2 Untagged (DMZ)
    VLAN 20: Port 1 & 4 Untagged (PC)
    VLAN 30: Port 1, 5 & 6 Untagged (WIFI)
    Port 1 is trunk, intetnet is coming from it, the only connection to pfSense router.
    Other ports are connected to various devices and the leftovers from the 8 ports I got aren't used atm.
    PVID: Port 1: 1
    Port 2: 10
    Port 4: 20
    Port 5 & 6: 30

    As I read, everything should work like a charm now. But wherever I connect on the switch with my computer, I always get dhcp adress from normal LAN, like it's completely ignoring the VLANs...
    Any help? Thanks in advance.



  • How would I make port 1 a trunk port, with all the VLANs coming from pfSense? Should I just set it as tagged insted of untagged on the switch for all the VLANs I got on the switch?



  • I have the same router (8 port version), one issue I found was that the save config option works only once. So if you configured it saved and made other changes and saved again, the second set of changes does not persist reboots. So make all your vlan entries, (do PVIDs too if required for the access ports) and save it once. Do a reboot / unplug and plug the power and check if the settings persisted and try deploying the switch. Also, port 1 needs to be tagged for all VLANs in your setup.



  • @dbinoj I'll try that as soon as I get home. Thanks :)