Unable to boot when network cables plugged in



  • Hi, hope someone can help.
    I've recently bought a Dell R210II (Xeon E3, 4GB RAM) and Intel i350-T4 but it refuses to boot when the network cables are plugged in.
    There are 4 interfaces configured for pfSense - all assigned to the Intel card. The internal network connections are not being used.

    It's random but 100% goes wrong when the cables are plugged in. It either:

    1. Freezes before the boot screen appears, with just the "/" showing.
    2. Gets to the boot screen and reboots immediately
    3. Gets to the boot screen and shows graphic corruption (green squares all over it).
      If the cables are unplugged it generally seems to boot and I can then plug in the cables but clearly this isn't desirable.

    pfSense install is ZFS using the latest - pfSense-CE-memstick-2.4.4-RELEASE-amd64.img.gz
    The BIOS and firmware on the network card are up to date.
    BIOS settings are at defaults.

    I tried a few things in the loader.conf.local like setting up igb defaults, disabling AGP, and forcing serial console setting.
    None of these seemed to help. Admittedly I may have used wrong combinations of settings as I was following other threads on here/online.

    Any ideas what I'm doing wrong?
    Thanks


  • Netgate Administrator

    That sort of random behaviour looks more like a hardware issue to be honest.

    Have you tried booting anything else? Run a memtest?

    If you do enable serial console can you get the boot output so we can see where it stops?

    Steve



  • Thanks for the reply Steve!
    When I first got the box the first thing I did was run the onboard diagnostics, updated the BIOS/iDRAC etc and also ran a memtest86 via Ultimate Boot CD for a day or so with no issues.
    I've been able to successfully boot Ubuntu 16.04LTS on the box.

    I'll try and sort out the log later as I haven't got that handy, but is there any additional boot parameters I can give for extra-verbose/debug output?

    My gut feeling is something IRQ related between the BIOS and pfSense boot-loader. It's almost feels like it's trying to handle packets of data coming in before the interface driver is fully configured and hitting end-of-world. And that might explain why having the cables removed during the boot-loader works.
    I can even plug them in after the boot-loader completes but before pfsense is loaded and it seems to work OK.

    Thanks.


  • Netgate Administrator

    Yes you cab boot verbose to get more detail. In some cases a LOT. 😉

    Add this to /boot/loader.conf.local: boot_verbose="YES"

    Or, for one time only, interrupt the boot loader and type boot -v

    Steve



  • Well...it's different (I'd say worse now)
    With a minimal bootloader.conf.local
    10-15 attempts with all cables in resulted in:

    1. Mostly just getting
    /
    

    on the screen (before BTX Loader gets printed)

    BTX Loader 1.00 BTX version is 1.02
    Consoles: internal video/keyboard
    BIOS drive C: is disk0
    BIOS 633KB/3111616kB available memory
    
    FreeBSD/x86 ZFS enabled boostrap loader, Revision 1
    (Tue Sep 4 22:35:48 EDT 2018 root@buildbot3)
    /
    
    1. A complete screenfull of repeating checkerboard repeating every 3 characters
    2. BTX Halted reg dump
    int=0000000d err=00000038 ef1=00010046 eip=00009094
    eax=00000013 ebx=00002820 ecx=00000038 edx=000008ee
    esi=00009601 edi=0000f598 ebp=00000000 esp=2a1fffff
    cs=0008 ds=0000 es=0000 fs=0000 gs=0000 ss=0010
    cs:eip=0f 00 d9 ba 00 a0 00 00-36 0f b7 05 13 04 00 00
           c1 e0 0a 2d 00 10 00 00-29 d0 b1 33 51 50 68 02
    ss:esp=a5 5a 5a 5a 5a a5 a5 a5-a5 5a 5a 5a 5a a5 a5 a5
           a5 5a 5a 5a 5a a5 a5 a5-a5 5a 5a 5a 5a a5 a5 a5
    BTX halted
    

  • Netgate Administrator

    Hmm, that's not even getting past the boot loader. At that point there are no drivers loaded nothing much network related could be happening there. It's past where it might be trying to PXE boot.

    I wonder if the card is pulling too much power? Or maybe there's some issue with PoE?

    Does it vary if you have only one cable connected?

    I'd still have to guess some hardware issue at this point. Maybe something FreeBSD is tickling that Linux doesn't. Just in the bootloader though it's hard to think what that might be. 😕

    Steve



  • I work on these generation servers from Dell regularly. They are approaching 10 years old and we have started seeing motherboard failures. As others have stated you are probably seeing some type of hardware failure.