2.4.4 Installation problems



  • My system consists of an Asrock Q1900-ITX motherboard with a quad core Celeron J1900 and 4 GB RAM. I had installed the 2.4.3 version and tried to upgrade to 2.4.4 from GUI. After failure I tried to do a clean install with 2.4.4 from a USB. In boot menu I get 2 options for the USB. The USB option and the UEFI option. When I choose the USB option it starts to the menu but after that it stops loading after the word Booting. In UEFI option it installs normally without a hitch but after reboot and removal of the USB I get a No System Disk or Boot Error like I don't have install anything on the drive. How can I fix that? I already tried two different disks, two different USB sticks and two different software to prepare the usb even downloading from two different mirrors





  • Thanks for the reply. But none of it worked. I am going to reinstall 2.4.3 and see what happens.



  • @grimson I reinstalled 2.4.3 and worked fine in bios mode. In UEFI it doesn't work. I tried an upgrade to 2.4.4 in clean installation but it failed miserably again. So what I have now is a firewall in 2.4.3 that cannot be upgraded, and I cannot perform a clean install in 2.4.4 in either bios or UEFI mode. The problem in UEFI does not come from hardware because I performed a bios and UEFI update and tried uefi install of ubuntu and It was succesful. So the problem is bios installation of 2.4.4 that doesn't boot. any ideas?



  • Make sure it really isn't booting in bios mode and you're not just running into the console issue from the upgrade guide, pfSense 2.4.4 runs otherwise fine on J1900 systems.



  • i have the same board and i to am having no luck installing 2.4.4 from the web page or a freash install via usb



  • @dave234ee after a lot of searching for this problem I found this :

    https://protectli.com/kb/pfsense-ce-2-4-4-on-the-vault/

    I followed the installation procedure and it works. Just be careful not to do the same mistake I did in step 3. In loader.conf I mistakenly added the command set kern.vty="sc" whereas the set is not needed and I believed that it didn't work. So be careful of the details and it will work



  • @ovidius thanks for that carried out the edit before running the update and all is good again on 2.4.4 thanks for your help



  • Lol, the solution was already documented in the upgrade guide I linked above. 🤣


  • Netgate Administrator

    Those instructions, at protectli, are incorrect. You should put that loader variable in /boot/loader.conf.local to avoid having it overwritten at a firmware update.

    Steve



  • @grimson only the part about upgrade was in the instructions you linked. The part needed for the clean installation wasn't there or rather it was there but stuck to the instructions for atom processors



  • @ovidius said in 2.4.4 Installation problems:

    @grimson only the part about upgrade was in the instructions you linked. The part needed for the clean installation wasn't there or rather it was there but stuck to the instructions for atom processors.

    The boot troubleshooting guide I linked contains various parts where you change variables before or during the installation process, also how to add them to "/boot/loader.conf.local". It's not that complicated to combine those two for a solution, just takes a few minutes of thinking.

    As for the J1900, it's marketed as an Celeron but it is actually Atom under the hood.
    Have a look at: https://ark.intel.com/en/products/78867/Intel-Celeron-Processor-J1900-2M-Cache-up-to-2-42-GHz for the integrated graphics

    Intel® HD Graphics for Intel Atom® Processor Z3700 Series

    You should know the hardware you use.



  • @grimson first of all when the motherboard company says that I have a celeron and intel herself calls the processor Celeron it is a celeron. That the Intel HD Graphics is for atom and not the standard it was something that I didn't see and expect as Intel herself calls the processor Celeron. That is for the processor part. As for the rest of the solution the solution is incomplete because in order to be able to write to /boot/loader.conf.local first you must be able to run installation then run first configuration and then write in loader.conf.local. The solution given in the link you posted was very vague so it was more confusing than helpfull. I quote from there:

    ***Intel Atom systems containing HD Graphics chipsets may experience console problems after the update. Affected systems will boot successfully, but fail to display console output after the boot menu. To fix the problem, add the following line to /boot/loader.conf.local to use the syscons console type:

    kern.vty=sc***
    My problem wasn't helped here because my pc didn't boot successfully. It was stuck in booting. So it wasn't something so simple as you say and it wasn't something solvable with a few minutes of thinking. You see for someone that is not very familiar with freebsd I wouldn't know what to do and I would need specific and not vague instructions. As for the mistake stephenw10 is referring to, it's minor and a lesser problem because those"mistaken" instructions allowed me to solve my problem whereas the right instructions from the link you posted did nothing of sorts. They just confused me more. When you write instructions for non professionals be specific. Anyway Thank you for your replies


  • Netgate Administrator

    It's a minor difference I agree but an important one. It will work in loader.conf but do you really want to go through this again if it gets overwritten at the next firmware update? 😉

    Steve



  • Your system in all likelyhood booted, it just didn't show any more output in the graphics console. You could have connected via SSH or the WebUI. As for the rest, as I said the boot troubleshooting guide contains the needed instructions.

    But if you rather spend hours searching instead of minutes thinking be my guest, it is amusing after all: 😁

    Btw. your firm believe in marketed product names is funny as well. 🤣



  • @stephenw10 Absolutely not and thank you giving me the right instructions. The thing is that with the with the right but vague instructions from netgate I couldn't proceed the installation and have a working system. On the other hand with their mistaken instructions I completed the installation and I have a working system. So if anything happened and I had to do a clean installation again I would now know what to do to get a working system again. Now thanks to you, giving me the last piece of the puzzle I have the whole solution. Again Thanks for the help but have in mind that you need to give specific instructions so that all can follow.



  • @grimson Actually I couldn't ssh or WebGui connect because I couldn't know it booted. I just saw it suck in booting. So you can call me dumb but I would like to know what would you do when finding a problem totally new to you. I tried what ever I could think for hours before coming to the forum but that wasn't something I could think because I don't have the experience. The link you sent I had already seen but it didn't help because it was VAGUE and for that reason unhelpful.Now, as for the marketed product names I am sorry if I can't read between the lines IN THE OFFICIAL PRODUCT PAGE and find that my intel called Celeron processor isn't a Celeron but an ATOM. So again call me dumb or an idiot and proceed.