pfBlocker install breaks PHP



  • Hi There

    I am on build 2.4.2 and went to install pfBlocker and now have no WebGUI and only remote access.

    This is the error I get when I try and open the normal log in page:

    PHP ERROR: Type: 64, File: /etc/inc/config.inc, Line: 51, Message: require_once(): Failed opening required 'Net/IPv6.php' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form:/usr/local/share/pear')

    When I go an have a look at the console I can see the following:
    0_1538386259694_PF Sense Capture.PNG

    Any ideas on how to save this install?

    By my research and the looks of it the version of pfBlocker was not compatible with my version of pfSense.
    Cheers
    PDANZ



  • @pdanz
    I am having the exact same issue using build 2.4.3_1. Has anyone responded on a way to recover?

    Thanks,



  • https://forum.netgate.com/search quite a few threads about this issue exist already.



  • This is the bug that has been logged:

    https://redmine.pfsense.org/issues/8938

    My question now is how can I roll back this issue and get the webgui functional again.

    Is there a way I can uninstall pfblocker from the command line and fix the php to use 5.6 again instead of 7.2?

    Thanks for any suggestions in advance.



  • Alternatively rather than trying to roll back the failed install of pfBlocker I would be willing to try and upgrade to 2.4.4 from 2.4.2 using the command line if this is known to fix the issue?

    Anyone know if this will resolve the PHP issues if I upgrade from the command line to 2.4.4?

    Cheers
    PDANZ



  • It is known that 2.4.4 included a major update in php, which obviously creates havoc in previous versions requiring older php builds.
    I'm no pfsense upgrade expert, but it is safe to assume that if one manages to bring the system to use php 7.2 then all the available packages will work after an automated reinstall to latest, since they are built to use php7.2 .
    (It is very unfortunate that available packages are changed to support 7.2 breaking all backwards compatibility too, but that's another story. Having said that, yes, it is a major undertaking to build a modern versioning system which could support a compatibility matrix of what version should go to which pf version, but until then, it is rather straight forward to give us duplicated entries of packages, with bold letters saying THIS is for 2.4.4 and later, and the previous ones, as an interim solution)



  • @techn01ddr01d hi there

    I was able to fix this by following the instructions Tubal listed on this reddit thread:

    https://www.reddit.com/r/PFSENSE/comments/9il2u0/pfblockerng_install_broke_my_installation/

    To fix this I:
    
    Updated /usr/local/etc/pkg/repos/pfSense.conf to point the repos back to 2.4.3
    
    Run pkg update
    
    Removed php72 ('pkg delete php72')
    
    Reinstall missing packages ('pkg check -d')
    

    Then I was good to go. In my case I was pointing to 2.4.2 but the same will apply for you but use 2.4.3

    Fixed all my issues :)

    Let us know how you go.

    Cheers
    PDANZ