Rescue/fail-safe access to the eMMC on the SG-1000.



  • I tried to upgrade my SG-1000 from 2.4.3 to 2.4.4 /via seriel console), but after the upgrade, which seems to have gone just fine, it will not start properly. All I get are endless of lines looking like this:
    Welcome to pfSense ...
    ...done.
    Launching the init system...Starting CRON... done.
    Warning: Failed loading Zend extension 'opcache.so' (tried: /usr/local/lib/php/20131226/opcache.so (Cannot open "/usr/local/lib/php/20131226/opcache.so"), /usr/local/lib/php/20131226/opcache.so.so (Cannot open "/usr/local/lib/php/20131226/opcache.so.so"0
    Warning: PHP Startup: Unable to load dynamic library 'session.so' (tried: /usr/local/lib/php/20131226/session.so (Cannot open "/usr/local/lib/php/20131226/session.so"), /usr/local/lib/php/20131226/session.so.so (Cannot open "/usr/local/lib/php/20131226/0

    And after a lot of these lines, it ends up at :
    pfSense arm
    Bootup complete

    But it's not working.

    I's a non-critical test firewall, but I still would like to get a copy of the config.xml that is on the device, I have no backup.

    All I can find is pfSense-netgate-uFW-recover-2.4.3-RELEASE-p1-armv6.img and pfSense-netgate-SG-1000-recover-2.4.4-RELEASE-armv6.img, but these only offer me to reinstall and wipe the disk completely, like this:
    "This will install the standard firmware and will erase all the existing
    contents of eMMC permanently."

    The normal installer has the options "Rescue shell" and "Recover config.xml", is there an image out there with these options also for the SG-1000?


  • Rebel Alliance Developer Netgate

    Not currently. That system is an ARM unit that requires a special image and it doesn't have a traditional installer. The recovery process for that model doesn't have a function to recover the configuration from the drive.

    Does your old installation boot at all? If you can get to a shell prompt, then it's probably possible to mount a USB drive (DOS or FAT32 formatted) and copy the configuration off that way.



  • It boots, pretty far, but ends ut dead stuck and non-responsive at:
    pfSense arm
    Bootup complete

    but before that, I have the uboot prompt, and "another one"/"loader>" after that, but no full bsd shell,, but I'm not sure what to do there. You have any instructions for me?


  • Rebel Alliance Developer Netgate

    Anything happen if you hit Ctrl-C at any point earlier in the boot process?

    Or from the loader prompt, try boot -s.



  • Thanks a million Jim! boot -s did the trick!