dns resolver not resolving dns names

  • hi all,

    since I updated my pfsense box to 2.4.4 my dns doesn't work

    on my home page my WAN is up under "interfaces" but under "gateways" my WAN_PPPOE is offline

    when I go to "diagnostics>ping" I can ping but can't resolve Google.co.uk

    im using dns resolver and I have flicked it to dns forwarder and back again but still no joy, also tried a reboot

    it may be my ISP so going to call them tomorrow to check if there having dns issues in my area


  • This post is deleted!

  • This post is deleted!

  • found out it's my pfsense box as I have luckily a wireless router and it works with my modem so have to re install pfsense on my box again

  • re-installed pfsense on my APU box with 2.4.4 and all works but when i changed the dns resolver config, it crashed out on me again so i def think its with the new version of pfsense and dns

  • LAYER 8 Global Moderator

    Its not pfsense 2.4.4 if it was there board would be flooded with problems.. Resolver is working just fine.. How about you test something vs saying it doesn't work.

    So when you use the diag dns lookup what do you get? What does the resolver log say? If pfsense sends a query and you get no answer that is not on pfsense.

    but when i changed the dns resolver config, it crashed out

    Changed it to WHAT?? You said it worked... What was the crash?

  • Rebel Alliance Developer Netgate

    If you received an error message, please post the full and exact contents of the error message or log entry in question.

  • Do you see any arpresolve error messages in your logs? What is the MTU of your WAN interface?

  • sorry been busy at work and the only time i can look at this is when i get back home late evening.

    i dont think its a dns resolve issue as i did another re-install of pfsense on my APU board (2.4.4) and i installed the openvpn client exporter and the whole pfsense box was acting really slow and crashed out on me yet again

    it seems like after a fresh re-install of 2.4.4 its all ok and running smoothly but after i install a package or like before with dns adding a custom commnd to it the whole machine acts really slow and crashes all the time

    it maybe hardware related

    sorry i dont know what the error is yet but if i have time i will do some more homework and get back to you

  • LAYER 8 Global Moderator

    @robina80 said in dns resolver not resolving dns names:

    dns adding a custom commnd to it the whole

    What are you adding??

  • pfSense DNS Resolver

    Similarly, if you are using pfSense’s internal DNS resolver service, you’ll want to adjust that configuration. In the pfSense web UI, go to Services > DNS Resolver, click Display Custom Options, and enter the following the the text box:

    private-domain: "plex.direct"

    but it wasnt just this that pfsense crashed on it crashed while i was installing openvpn client exporter so i really dont know why it kept on crashing

    in the end i installed OPNsense and added the custom dns config and also set up openvpn server and it all works perfect now

    for the time being im going to use OPNsense but it is far less superior than pfsense

Log in to reply