Where to Find Packages for 2.4.3_1?



  • A clean install of 2.4.3_1 results in being unable to download any packages.

    However, restoring a config XML file that used packages, results in a corrupt package manager that thinks it's running 2.4.4. Because of different PHP versions, there are numerous PHP crashes in the GUI and no packages seem to work.

    I'd like to stay on 2.4.3_1 until the dust settles on 2.4.4 (or patch 1 is released). Where can I download previous release of packages? I'm running on ARM32 architecture.

    PS Upon reflection, the pfSense team would have been wiser to start a new branch 2.5.0 instead of this 2.4.4 fiasco, becasue of the PHP and FreeBSD major updates.



  • @msf2000 said in Where to Find Packages for 2.4.3_1?:

    Where can I download previous release of packages?

    You can't.

    You could checkout the sources for the packages on a commit before the switch to PHP 7.2 and then build them yourself and install them manually, if you know how to do it.