Unable to configure two PPPoE WAN connections



  • Hello,

    I am hoping this is the correct categorie for posting my problem.

    A client of us uses a pfSense firewall with two WAN ports. I am able to configure the first PPPoE for the WAN interface. But I am unable to change any settings for that particular interface afterwards. This also occurs when I try to add the second PPPoE to the second WAN interface.

    The error message is: "The service name contains invalid characters".
    I have tried several things - like removing the colon from the "Service Name. The error message stays away but it terminates my PPPoE connection.

    This problem occurs when I use a ZyXEL SBG3300-N configured in brdige mode.
    This problem does not occur when I use a Draytek Vigor130 in bridge mode because the service name is not required in such a case.

    Is there a way to workaround this problem? I have tried to configure the WAN and next to assign the PPPoE to the OPT port and next to run the wizard again, but I could not get this to work unfortunately. Maybe I could manipulate the config via SSH?

    I have filed a bug report for pfSense: https://redmine.pfsense.org/issues/9002
    I am hoping someone picks it up from there? I am not sure how this works.

    alt text
    alt text



  • Hello, This has been fixed by Steve Beaver. I have tested the changes on my firewalls and this solves the issue for me. Many thanks.

    https://redmine.pfsense.org/projects/pfsense/repository/revisions/dac4cd09699bdafa5bcf1cf7b699438e5f669b26 (check the diff file)