Can't delete gateway because it's in use...but it doesn't exist!



  • I had an interface defined for which I defined a gateway and that gateway was used in a couple of gateway groups. That interface was deleted because it didn't exist any more.

    I can't delete the gateway for the deleted interface because "it is in use in a gateway group." However, it does not appear in the definition of the gateway group.

    How do I get rid of this rogue, ghost gateway?

    Thanks, Dave


  • Rebel Alliance Developer Netgate

    Download a backup of config.xml from Diagnostics > Backup & Restore and check for reference(s) to the gateway name it's complaining about. There must be something in there that it's flagging.



  • OK, I found 11 references to the undefined interface in the config.xml file. Some of the references are for the gateway I can't delete.

    Can I just remove all references to the interface in the config.xml file and reload the config.xml file? I can probably figure out how to do that, but I might make a mistake. Can I screw up the pfSense router to the point that I can't recover and reload the original file?

    Thanks,
    Dave



  • I tried to post config.xml changes I would make, but the Website says the posting was SPAM and rejected it!



  • Recreate the Interface and add the gateway. Then go through the process of removing the gateway. I ran into the same issue, but I had disabled the interface instead of deleting it. Just go back and add it, and then go through the process of deleting the gateway.



  • Thanks! That worked.