pfSense proxy auth settings not applied



  • Hello guys,

    Have anyone ever faced the issue where pfSense box needs to go through a web proxy with authentication for Internet (HTTP) connectivity but it doesn't work?

    My configuration is the following:

    [2.4.4-RELEASE][admin@pfs01.example.local]/root: env | grep PROX
    HTTP_PROXY=proxyserver:9090
    HTTP_PROXY_AUTH=basic:*:user:password
    

    However I am getting the error below:

    [2.4.4-RELEASE][admin@pfs01.example.local]/root: pkg update -f
    Updating pfSense-core repository catalogue...
    pkg: Repository pfSense-core load error: access repo file(/var/db/pkg/repo-pfSense-core.sqlite) failed: No such file or directory
    pkg: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-core/meta.txz: Proxy Authentication Required
    repository pfSense-core has no meta file, using default settings
    pkg: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-core/packagesite.txz: Proxy Authentication Required
    Unable to update repository pfSense-core
    Updating pfSense repository catalogue...
    pkg: Repository pfSense load error: access repo file(/var/db/pkg/repo-pfSense.sqlite) failed: No such file or directory
    pkg: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-pfSense_v2_4_4/meta.txz: Proxy Authentication Required
    repository pfSense has no meta file, using default settings
    pkg: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-pfSense_v2_4_4/packagesite.txz: Proxy Authentication Required
    Unable to update repository pfSense
    Error updating repositories!
    

    This is a brand new 2.4.4 installation.

    Thank you!


  • Rebel Alliance Developer Netgate

    Looks like it broke again in FreeBSD 11.2: https://redmine.pfsense.org/issues/9029

    We'll look into it, but it may be something that needs raised upstream with FreeBSD for them to fix.



  • @jimp said in pfSense proxy auth settings not applied:

    Looks like it broke again in FreeBSD 11.2: https://redmine.pfsense.org/issues/9029

    We'll look into it, but it may be something that needs raised upstream with FreeBSD for them to fix.

    Thanks for your quick reply, @jimp.
    I'll be waiting on feedback for that particular bug report.