DHCP Retry on WAN Interface



  • I am running pfSense 2.4.4 on a PCEngine APU2C4, my ISP is Comcast and I'm using a Motorola Surfboard SB6183 modem.

    I've been having a problem for a while now that the WAN interface on my firewall will randomly lose it's DHCP assigned Internet IP address. When this happens, I usually just have to log into the web management interface and renew the interfaces IP address, but this seems to be happening more lately. It seems to have gotten worse since the 2.4.4 upgrade, but it was happening before as well.

    Is there a setting that I can check that could help with this problem?


  • Netgate Administrator

    When that happens does it end up with a bad address or simply no address?

    Check the dhclient entries in the DHCP logs.

    Check if system log shows and errors at the time it failed.

    Steve



  • No address at all.



  • Fire up Packet Capture and see what's happening or not happening. You may find it easier to download the capture and use Wireshark to examine it.
    .


  • Netgate Administrator

    Yes, if there's no errors shown then check a packet capture but I'd expect to see something in one of those logs when it fails to renew the lease (or fetch a new one).

    Steve



  • Sorry for reviving an old thread but I think I may have accidentally stumbled on to a fix for this.

    I was changing some settings for my WAN interface and accidentally clicked on the Advanced Configuration Options for the DHCP Client and noticed that all of the protocol timing variables were set to null values and that the presets were set to the saved config. I reverted this back to the pfSense default values.


  • Netgate Administrator

    If you have any advanced DHCP options set the default settings are overridden but what is added should still be valid there.
    Were you able to check the values in the generated conf file? For example /var/etc/dhclient_wan.conf

    Steve