Connecting two Pfsenses

  • Hello,

    I need to connect both Pfsenses on Opt1 and I need a working Internet connection at Pfsense 2 Lan1.
    I added Static Routes but from Opt1 to Opt1 but its not working. Cant even ping the other Opt... now i deleted all my changes and wait for help...
    WAN IP is
    Internet Connection on Pfsense 1 Lan 1 is working.

    How do i Setup the Opt1's and what i need to do get Internet on Lan1 (Pfsense2).


  • @kleber said in Connecting two Pfsenses:

    Cant even ping the other Opt...

    What are the network settings on the OPTs?

    Just configure both with IPs within the same network.
    On pfSense2 add the OPT1 address of pfSense1 as a gateway and set it as default GW.
    On pfSense1 add the OPT1 address of pfSense2 as gateway. Then add a static route for and select this gateway for the route.

    On pfSense2 disable the outbound NAT if you don't need it for other purposes.

  • I'm trying to get a similar thing working. I want workstations on LAN A to be able to use the WAN connection on pfSense B if the WAN on pfSense A goes down. (And vice-versa) I'm still working on it, and I'll let you know if I make progress. At the moment we have two WAN connections at each of the two buildings. I hope to be able to get rid of one connection at each building and maintain redundancy with the WiFi link.
    Edit:- OK, so this "just works" if I follow viragomann's instructions. (Thank you!) I made the WiFi link as a subnet connecting OPT1 on each pfSense giving each OPT1 an IP address in that subnet. Then on each pfSense make a new gateway in system -> routing which points to the other pfSenses OPT1 IP address. Don't forget to fix up the OPT1 interfaces' firewall rules, of course. Then I also added a static route using the new gateways so that workstations on LAN A and see workstations on LAN B (and vice versa) via the WiFi link.
    Now, if I pull the WAN on one pfSense, traffic then goes via the link and out to the WAN on the other. Works like a charm. Next I'll try load sharing.

Log in to reply