BUG FOUND - FIX Included (Simple User Managment Bug)



  • Wile trying to get pfSense 2.0 to work as an IPSec VPN Server I
    came across this issue and thought I might as well point it out…

    If you create a user via the WebGUI (System: User Manager) the
    user will appear to have been created OK.
    If you then try to give this user the 'User - Shell account access'
    privilege, again it will seem to have worked, but this user will not
    be able to login.
    After some investigation it seemed that the user was never really
    created @ the system level at least. After looking over teh code
    i tried to emulate the steps of the .php files from teh cli over ssh.
    I could not create the user with the commands the .php files
    where using due the the fact the user is supposed to be added to
    a system group called 'all'.This group does not seem to exist
    after an install of pfSense-2.0-ALPHA-ALPHA-20090214-0228
    or pfSense-2.0-ALPHA-ALPHA-20090224-1130.
    After manually adding the group to the /etc/group file and re-trying
    teh command from teh cli, the user was created and could then login
    via SSH. This simple fix of adding the group also solved this issue
    of the users not being created when using the WebGUI as well.

    Hope this helps.

    DaGeek



  • Try latest snapshots.


Log in to reply