sg 3100 Lan Interface NAT not working



  • I recently got my Netgate SG-3100. I tried setting up NAT and Virtual IPs. Everything is working fine until I setup a NAT Port Forwarding for LAN interface. I'm not sure if I miss something.

    What I'm trying to do is, when a device that is connected to the internal network (connected to my Netgate SG-3100) try to connect to the WAN address throught port 80 and port 22, It should redirect to my server. It is working fine when the device trying to connect is outside of the private network. Any advice?


  • Rebel Alliance Global Moderator

    That is nat reflection - which you have to enable... And to be honest is not optimal.. If your already on the internal network just connect to the internal IP.. Do a simple host override so the fqdn your using (ie your wan ddns or whatever) resolves to your local IP for the box your wanting to connect too.

    Nat reflection is never going to be the first choice.. Its an abomination if you ask me ;)



  • Thank you for your quick reply. The reason why I don't connect to the internal IP manually is because I have a domain that is pointed to the IP of my netgate. If i'm inside the network, that domain will not be reachable. Anyway I'll look into the host override.



  • UPDATE: I tried to set Destination address to any instead of WAN or LAN net and it suddenly works without enabling NAT reflection.


  • Rebel Alliance Global Moderator

    huh? No sorry it doesn't work that way.

    @cgalgo said in sg 3100 Lan Interface NAT not working:

    I have a domain that is pointed to the IP of my netgate

    So? That is the whole point of a host override... Lets your internal server IP is 192.168.1.100, and you have some public fqdn that points to your public IP 1.2.3.4... Lets say this is host.domain.tld - then just create a host override that says if you go to host.domain.tld it returns 192.168.1.100



  • I thought it was working, but every HTTP site I tried to connect is redirecting to my server. ☹

    I also tried NAT reflection using Pure NAT and NAT + but it still not working. Will try look at the host override now



  • @johnpoz It's already working. I found this article https://www.netgate.com/docs/pfsense/nat/accessing-port-forwards-from-local-networks.html and use NAT Reflection for now. I will still look at the host override solution. Thanks for your help