Fresh v2.4.4 install on a Jetway NF93R saga - USB cannot boot and monitor Flicker



  • So, I finally decided to build my own pfsense box for home use. At first, I played with pfsense running on a VM under Virtualbox on my laptop for some time, while trying to decide what hardware to get. I decided for a Jetway NF93R Mini-ITX with Atom CPU 2GB RAM and Dual Gigabit Lan - Unfortunately Realtek NICs.

    The installation wasn't straight forward as I was expecting, but at the end I was able to complete it. I want to share me experience here as it may help someone else facing the same problems:

    #1 - Cannot boot from USB
    I couldn´t boot the USB Stick loaded with the PFsense v2.4.4 image at all. I tried to find a solution at the forum and the net, but no success. It is worth to mention that I was able to boot the same USB stick with an image of Fedora and also with a gparted image, so there is nothing wrong with the USB Stick and the MoBo. Probably the combination of this items. To be honest I could not solve this issue and then tried a different apporach: Connect the sata disk on a laptop and install Pfsense image from it. First I tried to use the Sata disk as an external USB disk, but the installation wouldn't complete. Then I replaced the internal disk with the target disk and the installation was ok. First issue Solved!

    #2 - Monitor Flicker
    After moving the Sata Disk to the original Mobo I was able to boot Pfsense, however, after switching to multiuser session the monitor starts flickering and merging lines at the top of the screen, preventing me to complete the installation steps. Spent another day trying to tweak BIOS settings and testing different cables and monitors, I found a solution at Reddit Forum: "It's possible your hardware doesn't like the vt console Edit (or create) /boot/loader.conf.local and set:
    kern.vty=sc"

    That's it. Hope it can help someone else.

    Regards.