*Solved / OVPN client pfsense 2.4.4 -> to specific lan addresses as gateway not functioning as expected



  • Hi,
    Having upgraded to 2.4.4 not sure at what point but this has stopped working.
    I have couple VPN client session which are configured as gateways to specified lan address. Like this:

    https://support.nordvpn.com/#/Connectivity/Router/1136266682/Pfsense-2-4-3-Selective-Routing.htm

    The problem is all my selective connection ie 192.168.0.18 & 192.168.1.40 is getting real public ip, not the VPN providers one..so nice :|

    There seems to have gotten some changes as now the gateways have own tables for rules as it was not like this before, so what have I misconfigured can't understand myself.

    1. openvpn clients have connected
    2. there is rules for these internal ip addresses to go to trough vpn gateway
      clients get real public ip :(

    in old pfsense

    1. openvpn clients have connected
    2. there is rules for these internal ip addresses to go to trough vpn gateway
    3. clients get vpn providers ip
    4. if ovpn clients go down the hosts cannot communicate (kill switch)

    #1 question: why is there no traffic going through ovpn gateways?
    #2 question: what the heck should be put on new gateway firewall rule table .. allow all, not allow all, allow specific?

    thank ahead guys!!
    image of settings



  • Or to add either I have zero conntection or the connection is through public wan not the wanted gateway. Seems like if I tinker something or reboot the fw it either stops traffic to outside (not internal network) or connects through default wan gateway..



  • Hi,

    Actually I got it figured out, it was compression problem!
    Maybe here was too many things wrong and change of things, for one I used now different VPN service as earlier. For second there might have been something wrong in the rules as I when my public ip was in use on the host which should have not been.
    Dunno, but now it is working as intended.

    1. Connection is off when tunnel is down.
    2. Correct compression setting in the vpn config started the packet flow.

    So ***Solved