Emule on pfsense



  • Hello, I began some days ago working with pfsense (it`s incredible!) and after lots of test I can't connect a computer to emule without lowid. I explaind what i have done:

    • NATed emule port (in my case 34375 TCP/UDP) from any to the computer.
    • Rule WAN to permit incoming traffic from any to the computer port 34375.

    And no way, always LOWID.

    Could someone help me?

    Thank you in advance.

    PD: Is it possible to group firewall logs into rules???



  • Should be the same like this: http://forum.pfsense.org/index.php?topic=1322.0

    And no, there is no firewall logs group function. You might want to send you systemlogs to a remote syslogserver and do the goruping/sorting with an external program if needed.



  • Could you please explaind me what is Outbound NAT an dhow it works??, I have been looking on monowall doc and I can´t find anything related.

    Thank you



  • When I try to create a Outbound NAT I receive this error (in System logs):

    php: : There were error(s) loading the rules: /tmp/rules.debug:22: the 'static-port' option can't be used when specifying a port range pfctl: Syntax error in config file: pf rules not loaded - The line in question reads [22]: nat on $wan from any to any port 34375 -> (xl1) port 34375 static-port



  • Enable advanced outbound NAT (it will create a default rule for your LAN segment). On top of this rule place this rule:

    Interface WAN
    Source Network, <ip of="" your="" p2p="" client="">/32, port 34375
    Destination any, port <empty>Translation Interface adress, port <empty>, static port [x]

    Save, Apply.

    After that you should reset the states at diagnostics>states, reset states to reestablish already established connections.</empty></empty></ip>



  • I have done it before and no way LOWID

    PD : (I think know I understand Oubound NAT)



  • Does your client have a desktopfirewall?



  • No, it doesn´t. I will explaind you my config because maybe thats the problem:

    I have one DSL with a Zyxel Wifi router (Spain telefonica with fixed IP) with all ports nated to my router 192.168.1.50, it could be the problem? Is the only way I know to connect my pfsense to the DSL.

    Thank you



  • In that case it might be an issue with the router in front of you not natting the connection correctly. You should get a pure pppoe modem that can bridge the connection to the pfsense and let the pfsense do the pppoe.



  • Hi again!

    I post here mi actual router configuration(zyxel.jpg) and the Bridge posibilities (adsl_bridge.jpg adsl_bridge2.jpg), as I don´t have any PPPoA user, I think I must use RFC1483. I have tried with this setting in pfsense Static Ip with my fixed DSL IP but I don´t have gateway (at least I don´t know it) to configure it. Could you please help me trying this?

    thanks in advance











  • Hi !

    What you have here is a "router behind router" setup.

    What you could do : Your Zyxel has to be used as a bridge => the Internet WAN adress will be offered to the WAN NIC of pFsense, you'll be up and running in no time. This is the so called PPPoE mode. Usernames and password has to given in pFsense.
    This problem isn't unique - try looking for solution in your country (concerning your ISP). You will not be the only one with this problem.

    Otherwise : not a real problem really.
    Give pFsense a static WAN IP - and its gateway IP on the WAN NIC will be the IP of the Zyxel Modem/router.
    Just NAT the right ports for emule in the Xyzl to the pFsense IP.
    You already natted the pFsense as it ought to be.

    This will work. I already used ones 3 routers in a row - still had a high-id …  ;)



  • Yes, it works but in reallity I don´t know why I have low id (I have the whole ports natted to pfsense). Everything else works perfect, and it´s not very important emule for me (I can do it with a computer in the middle of the routers) but I want to make it works.

    Are you sure that I should have a user and password for PPPOE even having fixed IP in my ISP?

    Thanks and it´s good to know that other people has the same config (router-router).



  • There are differnet ways ISPs are setting this up. Some give you PPPoE user and password and assign you always the same IP on dialin, others give you static IP/gateway/DNS to use at your end, others assign you parameters via DHCP. In all cases set the Modem to bridge mode and configure either PPPoE, Static or DHCP at your pfSense WAN with the settings your provider gave you.


Log in to reply