stupid question



  • I have just received my SG-1000 device.
    It is connected thus:
    Virgin smarthub3 --- wanport(SG-1000) (SG-1000)lanport --- raspebrry pi

    The raspberry pi has a fixed IP of 192.168.1.100 and can connect to the SG-1000 web interface.

    The SG-1000 says the WAN interface is up but shows no IP address for that interface.

    Using the web interface of the SG-1000 I have tried to resolve www.bbc.co.uk - it failed.
    I changed the configuration of the DNS system by adding the primary DNS server of VirginMedia (194.168.4.100).
    Again tried to resolve www.bbc.co.uk - failed.
    I enabled forwarding mode, still failing to resolve www.bbc.co.uk.
    Turned off DNS resolver, turned on DNS forwarder.
    Failed to resolve www.bbc.co.uk.
    Rebooted SG-1000, failed to resolve www.bbc.co.uk.
    Restored factory defaults.
    Failed to resolve www.bbc.co.uk.
    What am I doing wrong?

    FYI I also have other machines connected to this VirginMedia Superhub, /etc/resolve.conf is set to use the VirginMedia primary DNS and they can resolve www.bbc.co.uk so I know that address can be resolved by the server.
    No DHCP is in use anywhere. The Raspberry Pi has a fixed IP. It can use Chrome to display and configure the SG-1000 so I know that the LAN connection of the SG-1000 is working as expected.

    Screenshots/more information or explanations available on request.



  • What network is on the LAN port of the Smarthub? If it's 192.168.1.x as well it wont work, in that case you need to either change the Smarthubs LAN network or the SG-1000s LAN network. In any other case, show your screenshots with as much detail as possible.


  • Rebel Alliance Global Moderator

    @speaker-uk said in stupid question:

    shows no IP address for that interface.

    Then how do you think it could it work? LIke asking why there is no picture on the TV, when the TV is OFF ;)


  • Rebel Alliance



  • @grimson
    So how do I get the SG-1000 to force the Smarthub to give it an address?
    What do I change from the factory default to make this work?



  • @grimson
    Sorry I must not have made things very clear.

    The Smarthub has a network cat6e cable between it's WAN port and the Smarthub, connecting to one of the ethernet ports on the Smarthub.

    The LAN port on the SG-1000 is then connected via another cat6e network cable to the Raspberry Pi.

    The two ports of the SG-1000 do not share a network, rather the idea is the Pi talks to the SG-1000 on its LAN port and then the SG-1000 talks to the Smarthub on its WAN port.

    Hope that explains how I have it set-up



  • @rico

    But if I put the Smarthub into modem mode I will I not loose the ability to use it as a gateway device?

    It is connected as a gateway for a separate network that is behind a different firewall.
    All in all it serves as a gateway for four networks. The simple testing network I described here is just one of many.



  • VM Superhub usually defaults to 192.168.0.0/24 subnet so your LAN subnet of 192.168.1.0/24 should not conflict. . .. so far so good.

    Is the SG-1000 WAN configured for DHCP ? If so then it should receive a suitable IP & Gateway from the VM Hub. Ideally you should set the SG-1000 WAN with a static IP & Gateway in the VM subnet, but outside the VM DHCP range.

    Although this is double-NAT it works. side benefit is that when VM updates the Superhub software it doesn't break your IP network !! If you use Modem Mode, this gets reset during Docsis software updates.

    VM Superhub subnet = 192.168.0.0/24

    SG-1000 WAN
    IP Address = 192.168.0.253 /24
    WAN Gateway = 192.168.0.1 (VM Superhub IP)
    DNS Server = VM superhub 192.168.0.1

    SG-1000 LAN
    IP Address = 192.168.123.1 /24
    DNS Resolver = Enabled (Network Interfaces = ALL)
    DHCP Server = 192.168.123.101 to 199

    Also you need to Allow Private Networks on the WAN interface, otherwise the Superhub cannot communicate with the SG-1000 WAN.