Console Menu Missing after Password Protected



  • After selecting "Password Protect the Console Menu", it properly prompts me for my credentials. I enter my username and password. It appears to accept the credentials as there is no error. However, at that point, I don't get a menu. I simply get a prompt. Is this a bug? Is there something I can enter to make the menu appear?

    I definitely want to password protect the console, but if it's not visible after entering my credentials, it's not very useful. I've turned that feature off for now, until a solution can be found.

    Thanks.


  • Netgate Administrator

    Are you logging in as admin? (or root)

    In pfSense 2.4.4?

    Serial console or VGA?

    If you are logged in as admin or root or have sudo on your user you can run /etc/rc.initial to get the console menu.

    Steve


  • Rebel Alliance Developer Netgate

    If you are logging in as a user other than admin or root, then that is normal. You can install the sudo package and use sudo /etc/rc.initial to get the menu if you want. Otherwise a non-admin/root user does not have sufficient privileges to use many functions on the menu, so it gives a shell prompt instead.



  • That worked! Thanks! I just needed to be sure I had some way to reset admin password in case of an emergency. I have another 'sudo' admin which /etc/rc.initial worked perfectly.

    I also considered opening up SSH, but that might just be one more opening that someone could exploit.

    Anyway, thank's again.