Hyper-v & IPv6 = crash when enable track interface on LAN?



  • Hi,

    I have a Server 2019 (final, not beta) and I am running Hyper-V on it with pfSense 2.4.4
    When I enable IPv6 on the WAN and set LAN to track it I get crashing. Sometimes instantly and sometimes after a few seconds.
    I tried with hardware offloading on/off and all the hyper-v settings for the nic. Everything runs good otherwise if I keep v6 off though.

    The WAN does get an IP and I've tried playing around with other configs but all seems to stem around enabling the tracking.

    The end of the crash file has this if it helps but I couldn't find much though a ton of other info in logs exist so let me know if need something specific.

    <7>ifa_maintain_loopback_route: deletion failed for interface hn1: 3
    <7>ifa_maintain_loopback_route: insertion failed for interface hn1: 17
    <7>ifa_maintain_loopback_route: deletion failed for interface hn1: 3
    <7>ifa_maintain_loopback_route: insertion failed for interface hn1: 17

    Fatal trap 12: page fault while in kernel mode
    cpuid = 1; apic id = 01
    fault virtual address = 0xfffffe00ef72c4c1
    fault code = supervisor read data, page not present
    instruction pointer = 0x20:0xffffffff80fb4ff9
    stack pointer = 0x28:0xfffffe0098a8b5c0
    frame pointer = 0x28:0xfffffe0098a8b640
    code segment = base 0x0, limit 0xfffff, type 0x1b
    = DPL 0, pres 1, long 1, def32 0, gran 1
    processor eflags = interrupt enabled, resume, IOPL = 0



  • Is anyone running Hyper-v w/ v6 dhcp working from ISP on this latest pfsense??