pfSense startet nach Update nicht mehr



  • Hallo zusammen,

    ich habe heute das Update auf die aktuelle Version gemacht und seitdem startet meine APU nicht mehr. Das Update habe ich, wie immer, über die Weboberfläche gemacht. Es lief auch fehlerfrei durch. Als der Reboot-Timer immer wieder neu anlief, schaute ich über die Console.

    Da bekam ich folgendes Bild:
    0_1540997125985_Screenshot 2018-10-31 15.34.17.png
    Habe ich noch irgendeine Chance, außer einer Neuinstallation, das zu reparieren?

    Im Single User Mode versuche ich ein fsck. Hier bekomme ich leider nur das zu sehen:

    da0: Attempt to query device size failed: NOT READY, Medium not present
    da0: quirks=0x2<NO_6_BYTE>
    WARNING: / was not properly dismounted
    WARNING: /: mount pending error: blocks 230016 files 1782
    Enter full pathname of shell or RETURN for /bin/sh:
    Cannot read termcap database;
    using dumb terminal settings.
    Cannot read termcap database;
    using dumb terminal settings.
    # /sbin/fsck -y /
    # random: unblocking device.
    #
    

    Vielen Lieben Dank im Voraus.

    Marc



  • Mit der Recover Config Option drüber installieren geht wahrscheinlich viel schneller als nun ewig zu versuchen zu reparieren: https://www.netgate.com/docs/pfsense/backup/automatically-restore-during-install.html

    -Rico


  • Moderator

    Der erste Screen sieht eher so aus, als wäre das darunterliegende Medium (SD Card?) nicht mehr OK und hätte Blockfehler. Da kann man drüberinstallieren, klar, aber wenn das nicht nur beim Update auftritt würde ich eher überlegen das Medium zu tauschen. Ansonsten Neuinstallation mit Recovery der XML Datei (oder man hat ein aktuelles Backup) und gut, wäre sehr wahrscheinlich die schnellste Variante wie Rico schon richtig schreibt :)



  • Ich habe mir angewöhnt immer wenn ich mich auf dem pfSense WebIF einlogge vor jeder Änderung (auch wenn sie nur sehr klein ist) erst mal schnell ein Backup zu ziehen.
    Geht schnell und man schläft sehr gut. :-)

    -Rico