Rename Login Page Tab?
Is there any way to change the name pfSense gives the login page's tab in Google Chrome? Right now, that tab is named "Login." In itself, that's not a problem. But, the autotype feature of my password manager (KeePass) uses the tab name to determine which password to use and such a generic name results in false matches. Something like "pfSense Login" would be nice.
Grimson Banned last edited by
Use a different plugin that checks the URL instead of the tab name/page title. Your current plugin is rather insecure that way.
Good idea. I'll try a plugin that adds the URL to the tab title:
jclear last edited by
I believe he was suggesting a different password manager. If the password manager coder(s) made one insecure assumption (that a web page title would be unique), what other security mistakes does it contain?
This is probably not the best place to discuss the pros and cons of KeePass:
But, it doesn't automatically submit userids/passwords. Its Auto-Type ability is manually kicked off in various ways to fill in the appropriate fields once users determine they want to log in to a particular site:
So, as far as that goes, it has just as much user verification of a page's validity as manually entering the data. I've seen posts, though, discussing the very issue you've brought up. The stumbling block is that since KeePass is an independent application and not a browser extension, it doesn't have access to the actual URL of Chrome's current tab (I'm not a programmer, so I can't say one way or another if that's true).
Anyway, you're probably right in what Grimson was suggesting. But, it got me pointed in a direction where I could come up with a reasonable solution.
There isn't anything that changes the tab name, but there is an option to put the hostname on the login screen (System > General, Login hostname). That may not help, though.
It wouldn't be hard to code that up so that the checkbox also changes the title. If someone opts to have it in the body of the page I don't see why having it in the title would be any worse. Open a feature request on redmine and we can have a look.