upgrade to 2.4.4 failed.



  • Hi

    Upgrading from 2.4.3 release p1 to 2.4.4 and the Web GUI showed in RED failed.
    The screen output showed :

    Updating repositories metadata... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    done.
    pfSense repository is up to date.
    All repositories are up to date.
    2.4.4 version of pfSense is available
    Setting vital flag on pkg... done.
    Removing vital flag from lang/php56... done.
    Downloading upgrade packages... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking for upgrades (53 candidates): .......... done
    Processing candidates (53 candidates): .......... done
    The following 109 package(s) will be affected (of 0 checked):
    
    New packages to be INSTALLED:
    	php72: 7.2.10 [pfSense]
    	libargon2: 20171227 [pfSense]
    	php72-pecl-rrd: 2.0.1_1 [pfSense]
    	php72-simplepie: 1.5.1_1 [pfSense]
    	php72-curl: 7.2.10 [pfSense]
    	php72-tokenizer: 7.2.10 [pfSense]
    	php72-mbstring: 7.2.10 [pfSense]
    	oniguruma: 6.8.1 [pfSense]
    	php72-session: 7.2.10 [pfSense]
    	php72-opcache: 7.2.10 [pfSense]
    	php72-xmlwriter: 7.2.10 [pfSense]
    	php72-xmlreader: 7.2.10 [pfSense]
    	php72-dom: 7.2.10 [pfSense]
    	php72-xml: 7.2.10 [pfSense]
    	php72-simplexml: 7.2.10 [pfSense]
    	php72-ctype: 7.2.10 [pfSense]
    	php72-posix: 7.2.10 [pfSense]
    	sshguard: 2.2.0_4 [pfSense]
    	php72-openssl: 7.2.10 [pfSense]
    	php72-hash: 7.2.10 [pfSense]
    	php72-filter: 7.2.10 [pfSense]
    	php72-openssl_x509_crl: 1.2 [pfSense]
    	php72-bcmath: 7.2.10 [pfSense]
    	php72-pecl-mcrypt: 1.0.1 [pfSense]
    	php72-pear-Crypt_CHAP: 1.5.0 [pfSense]
    	php72-pear: 1.10.5_1 [pfSense]
    	php72-zlib: 7.2.10 [pfSense]
    	openvpn-auth-script: 1.0.0.3 [pfSense]
    	php72-sockets: 7.2.10 [pfSense]
    	php72-ldap: 7.2.10 [pfSense]
    	php72-pecl-zmq: 1.1.3_2 [pfSense]
    	php72-pecl-radius: 1.4.0.b1 [pfSense]
    	php72-pear-XML_RPC2: 1.1.3_1 [pfSense]
    	php72-pear-HTTP_Request2: 2.3.0,1 [pfSense]
    	php72-pear-Net_URL2: 2.2.1 [pfSense]
    	php72-pear-Cache_Lite: 1.7.16,1 [pfSense]
    	php72-pear-Net_IPv6: 1.3.0.b2_2 [pfSense]
    	php72-pear-Net_Growl: 2.7.0 [pfSense]
    	php72-pear-Auth_RADIUS: 1.1.0_4 [pfSense]
    	php72-pear-Mail: 1.4.1,1 [pfSense]
    	php72-pear-Net_SMTP: 1.8.0 [pfSense]
    	php72-pear-Net_Socket: 1.0.14 [pfSense]
    	php72-sysvshm: 7.2.10 [pfSense]
    	php72-sysvsem: 7.2.10 [pfSense]
    	php72-sysvmsg: 7.2.10 [pfSense]
    	php72-shmop: 7.2.10 [pfSense]
    	php72-readline: 7.2.10 [pfSense]
    	php72-pcntl: 7.2.10 [pfSense]
    	php72-json: 7.2.10 [pfSense]
    	php72-gettext: 7.2.10 [pfSense]
    	php72-pfSense-module: 0.64_6 [pfSense]
    	php72-sqlite3: 7.2.10 [pfSense]
    	php72-pdo_sqlite: 7.2.10 [pfSense]
    	php72-pdo: 7.2.10 [pfSense]
    	php72-bz2: 7.2.10 [pfSense]
    	libmaxminddb: 1.3.2 [pfSense]
    
    Installed packages to be UPGRADED:
    	webp: 0.6.1 -> 1.0.0 [pfSense]
    	unbound: 1.6.8 -> 1.8.1 [pfSense]
    	strongswan: 5.6.2_1 -> 5.7.1 [pfSense]
    	sqlite3: 3.22.0_1 -> 3.24.0_1 [pfSense]
    	rrdtool: 1.7.0_1 -> 1.7.0_2 [pfSense]
    	redis: 3.2.11 -> 4.0.10 [pfSense]
    	radvd: 2.17_4 -> 2.17_5 [pfSense]
    	python27: 2.7.14_1 -> 2.7.15 [pfSense]
    	py27-setuptools: 36.5.0 -> 39.2.0 [pfSense]
    	py27-ply: 3.10_1 -> 3.11 [pfSense]
    	pfSense-rc: 2.4.3_1 -> 2.4.4 [pfSense-core]
    	pfSense-pkg-ntopng: 0.8.12 -> 0.8.13_2 [pfSense]
    	pfSense-kernel-pfSense: 2.4.3_1 -> 2.4.4 [pfSense-core]
    	pfSense-default-config: 2.4.3_1 -> 2.4.4 [pfSense-core]
    	pfSense-base: 2.4.3_1 -> 2.4.4 [pfSense-core]
    	pfSense: 2.4.3_1 -> 2.4.4 [pfSense]
    	perl5: 5.24.4 -> 5.26.2 [pfSense]
    	pcre: 8.40_1 -> 8.42 [pfSense]
    	openvpn: 2.4.4_1 -> 2.4.6_1 [pfSense]
    	openldap-client: 2.4.45 -> 2.4.46 [pfSense]
    	ntp: 4.2.8p11 -> 4.2.8p12 [pfSense]
    	ntopng: 3.2.2018.03.13 -> 3.6.d201800910,1 [pfSense]
    	nginx: 1.12.2_3,2 -> 1.14.0_6,2 [pfSense]
    	ndpi: 2.2.2018.01.31 -> 2.4.d20180830,1 [pfSense]
    	mysql56-client: 5.6.39 -> 5.6.41 [pfSense]
    	mpd5: 5.8_3 -> 5.8_8 [pfSense]
    	mkfontscale: 1.1.2 -> 1.1.3 [pfSense]
    	miniupnpd: 1.9.20160113,1 -> 2.0.20180503,1 [pfSense]
    	links: 2.13,1 -> 2.16,1 [pfSense]
    	libzmq4: 4.2.2_1 -> 4.2.3 [pfSense]
    	libunistring: 0.9.8 -> 0.9.10 [pfSense]
    	libsodium: 1.0.15 -> 1.0.16 [pfSense]
    	libnghttp2: 1.31.1 -> 1.32.0 [pfSense]
    	liblz4: 1.8.0,1 -> 1.8.2,1 [pfSense]
    	libidn2: 2.0.4 -> 2.0.5 [pfSense]
    	libgd: 2.2.4_1,1 -> 2.2.5,1 [pfSense]
    	isc-dhcp43-server: 4.3.6P1 -> 4.3.6P1_1 [pfSense]
    	isc-dhcp43-relay: 4.3.6P1 -> 4.3.6P1_1 [pfSense]
    	igmpproxy: 0.1_5,1 -> 0.2.1_1,1 [pfSense]
    	hostapd: 2.6_1 -> 2.6_2 [pfSense]
    	graphviz: 2.40.1_2 -> 2.40.1_5 [pfSense]
    	glib: 2.50.3_1,1 -> 2.50.3_4,1 [pfSense]
    	freetype2: 2.8_1 -> 2.9.1 [pfSense]
    	fontconfig: 2.12.1,1 -> 2.12.6,1 [pfSense]
    	dnsmasq: 2.78,1 -> 2.79,1 [pfSense]
    	devcpu-data: 1.16 -> 1.19 [pfSense]
    	curl: 7.58.0 -> 7.62.0 [pfSense]
    	ca_root_nss: 3.36 -> 3.39 [pfSense]
    	bsnmp-regex: 0.6_1 -> 0.6_2 [pfSense]
    	bind-tools: 9.11.2P1 -> 9.12.2P1 [pfSense]
    	GeoIP: 1.6.11 -> 1.6.12 [pfSense]
    
    Installed packages to be REINSTALLED:
    	pfSense-Status_Monitoring-1.7.6 [pfSense] (direct dependency changed: php72)
    	mkfontdir-1.0.7 [pfSense] (ABI changed: 'freebsd:11:x86:64' -> 'freebsd:11:*')
    
    Number of packages to be installed: 56
    Number of packages to be upgraded: 51
    Number of packages to be reinstalled: 2
    
    The process will require 87 MiB more space.
    111 MiB to be downloaded.
    [1/109] Fetching webp-1.0.0.txz: .......... done
    [2/109] Fetching unbound-1.8.1.txz: .......... done
    [3/109] Fetching strongswan-5.7.1.txz: .......... done
    [4/109] Fetching sqlite3-3.24.0_1.txz: .......... done
    [5/109] Fetching rrdtool-1.7.0_2.txz: .......... done
    [6/109] Fetching redis-4.0.10.txz: .......... done
    [7/109] Fetching radvd-2.17_5.txz: .
    

    I left the box for a few minutes and then it restarted itself.
    Looking at the GUI it's now showing that it's running 2.4.4

    Is there anyway to confirm this has completed correctly ?

    Thanks



  • I should also mention, that I only have 2 packages installed:

    ntopng
    Status_Traffic_Totals

    Neither were touched prior to the upgrade.

    Everything 'looks' ok, all my interfaces are showing, IPSEC & openVPN connections are up.
    Routing via the different interfaces etc seems to be working as expected.

    I'd just like to ensure everything updated correctly.

    Thanks



  • Can anyone advise if there is anyway way to check everything upgraded correctly ?

    Thanks


  • Global Moderator

    In 2.4.4 Netgate started to use PHP7. So when you do update from previous versions (2.4.3_p1) there are lots of error/warning messages on a screen, but when update finishes and device reboots everything is working correctly.

    In your case I think during update terminal window changed, that's why you saw nothing.
    But if there are no crash reports or warning messages, your device works correctly.


  • Global Moderator

    to check that everything is OK - just reboot it and check if there are any errors/warnings during boot process



  • Thanks, I've not noticed any errors so hopefully all is good :)